summaryrefslogtreecommitdiff
path: root/extra/rust
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-11-28 10:40:04 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2019-11-28 10:40:04 +0100
commit413384dc19f1481f9145953a7ed5ad69346a8111 (patch)
tree44fcebd75e26096c03c672003491c5ccd631ae40 /extra/rust
parentf5976d3c284add0be71003027e3e2fe25c8b40b9 (diff)
downloadpackages-413384dc19f1481f9145953a7ed5ad69346a8111.tar.xz
extra/rust: another bootstrapping round
Diffstat (limited to 'extra/rust')
-rw-r--r--extra/rust/PKGBUILD30
-rwxr-xr-xextra/rust/watcher.sh2
2 files changed, 19 insertions, 13 deletions
diff --git a/extra/rust/PKGBUILD b/extra/rust/PKGBUILD
index 661d3419..6067e978 100644
--- a/extra/rust/PKGBUILD
+++ b/extra/rust/PKGBUILD
@@ -17,7 +17,7 @@ eval "$(
# stop insanity of nproc (see FS#62952)
eval "$(
- declare -f package_rust | \
+ declare -f build | \
sed '
s/-j"$(nproc)"/-j1/
'
@@ -52,34 +52,38 @@ eval "$(
'
)"
+eval "$(
+ declare -f build | \
+ sed '
+ /mv.*i686-unknown-linux-gnu.*/d
+ /ln /s/x86_64-unknown-linux-gnu/i686-unknown-linux-gnu/g
+ '
+)"
+
# watch for files changing which need patching during the x.py craziness!
# currently this is duplicate U1024 and P1024 types (this is currently needed
# for i686 and 1.38.0)
source+=('watcher.sh')
-sha256sums+=('a37ef742e079c7f7e80297bdb97115808b48f77fd92571468853de5cbd7ee800')
+sha256sums+=('c91b55a428ef463fc1529724da0c7f3930bd9d4b32b4596a14be77cc3f1e0594')
if [ "${CARCH}" = "i686" ]; then
makedepends+=('inotify-tools' 'procps-ng')
eval "$(
- declare -f package_rust | \
+ declare -f build | \
sed '
- /.\/x.py/ i \
+ /\.\/x.py/ i \
+ chmod u+x "$srcdir/watcher.sh" \
"$srcdir/watcher.sh" "$srcdir" & \
_kill_pid=$! \
sleep 10
- /.\/x.py/ a \
- kill $_kill_pid
+ /\.\/x.py/ a \
+ kill $_kill_pid || true
'
)"
fi
# Enable on demand, if your previous rust is broken, see also build-support and AUR
# for rust-bin.
-#makedepends=(${makedepends[@]//rust/})
-#makedepends+=('rust-bin')
-
-# links run away in upstream rust, we take extra and not trunk, is fixed in trunk upstream
-source[2]="http://releases.llvm.org/$_llvm_ver/compiler-rt-$_llvm_ver.src.tar.xz"
-source[3]="http://releases.llvm.org/$_llvm_ver/compiler-rt-$_llvm_ver.src.tar.xz.sig"
-sha256sums[2]="56e4cd96dd1d8c346b07b4d6b255f976570c6f2389697347a6c3dcb9e820d10e"
+makedepends=(${makedepends[@]//rust/})
+makedepends+=('rust-bin')
diff --git a/extra/rust/watcher.sh b/extra/rust/watcher.sh
index 544c3712..98228b5d 100755
--- a/extra/rust/watcher.sh
+++ b/extra/rust/watcher.sh
@@ -4,6 +4,8 @@ term() {
echo "--> Got SIGTERM"
echo "--> killing inotifywait with PID $inotifywait"
kill -TERM "$inotifywait"
+ sleep 10
+ kill -9 "$inotifywait"
}
srcdir="$1"