summaryrefslogtreecommitdiff
path: root/extra/rust/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-08-22 13:01:59 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-08-22 13:01:59 +0200
commit6686a3b2e8e2820b388ee0c38fb0febc3fe16ec6 (patch)
treefaec46839a922230830a01df89b20852252f94eb /extra/rust/PKGBUILD
parentf7ff499bced33669f48673e5abd572ce8ccea1d2 (diff)
downloadpackages-6686a3b2e8e2820b388ee0c38fb0febc3fe16ec6.tar.xz
extra/rust: no nproc, see FS#62952
Diffstat (limited to 'extra/rust/PKGBUILD')
-rw-r--r--extra/rust/PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/extra/rust/PKGBUILD b/extra/rust/PKGBUILD
index 0ab950b8..503f34a4 100644
--- a/extra/rust/PKGBUILD
+++ b/extra/rust/PKGBUILD
@@ -9,6 +9,15 @@ eval "$(
$ i patch -p1 -i "$srcdir/config.toml.patch"
'
)"
+
+# stop insanity of nproc (see FS#62952)
+eval "$(
+ declare -f build | \
+ sed '
+ s/-j"$(nproc)"/-j1/
+ '
+)"
+
if [ "${CARCH}" != 'pentium4' ]; then
eval "$(
declare -f prepare | \