summaryrefslogtreecommitdiff
path: root/extra/rust/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2020-04-19 17:38:09 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2020-04-19 17:38:09 +0200
commit5ae21ee05ad6d21c780fd64c85b80abe712bde26 (patch)
tree351c85bb7d3ded185815fc75090fbd4605d492d2 /extra/rust/PKGBUILD
parentb3aa86bc8342dc5dee66643f95596e52b4987f19 (diff)
downloadpackages-5ae21ee05ad6d21c780fd64c85b80abe712bde26.tar.xz
extra/rust: boostrapping rust 1.42 from rust141
Diffstat (limited to 'extra/rust/PKGBUILD')
-rw-r--r--extra/rust/PKGBUILD38
1 files changed, 19 insertions, 19 deletions
diff --git a/extra/rust/PKGBUILD b/extra/rust/PKGBUILD
index 6067e978..2df3a3eb 100644
--- a/extra/rust/PKGBUILD
+++ b/extra/rust/PKGBUILD
@@ -60,30 +60,30 @@ eval "$(
'
)"
-# watch for files changing which need patching during the x.py craziness!
-# currently this is duplicate U1024 and P1024 types (this is currently needed
-# for i686 and 1.38.0)
-source+=('watcher.sh')
-sha256sums+=('c91b55a428ef463fc1529724da0c7f3930bd9d4b32b4596a14be77cc3f1e0594')
-
+# work around P1024, U1024 typenum bug for old rust releases (bundled
+# typenum version contains a buggy version)
if [ "${CARCH}" = "i686" ]; then
- makedepends+=('inotify-tools' 'procps-ng')
-
+ source+=('rustc-1.42.0-src-typenum-U1024.patch')
+ sha256sums+=('716e5fad9b8bda690856d36f33359da26a4c258bb5e8ffd635898697177dc4de')
eval "$(
- declare -f build | \
+ declare -f prepare | \
sed '
- /\.\/x.py/ i \
- chmod u+x "$srcdir/watcher.sh" \
- "$srcdir/watcher.sh" "$srcdir" & \
- _kill_pid=$! \
- sleep 10
- /\.\/x.py/ a \
- kill $_kill_pid || true
+ /}/ i \
+ patch -Np1 < "$srcdir/rustc-1.42.0-src-typenum-U1024.patch"
'
)"
+
fi
-# Enable on demand, if your previous rust is broken, see also build-support and AUR
-# for rust-bin.
+# Enable on demand, if your previous rust is broken use previous version
+# from build-support
makedepends=(${makedepends[@]//rust/})
-makedepends+=('rust-bin')
+makedepends+=('rust141')
+
+# rust 1.41 is built against llvm 9.0, so force that in as a make dependency
+makedepends+=('llvm9-libs')
+
+# LLVM download location changed (also upstream)
+source[2]="https://github.com/llvm/llvm-project/releases/download/llvmorg-$_llvm_ver/compiler-rt-$_llvm_ver.src.tar.xz"
+source[3]="https://github.com/llvm/llvm-project/releases/download/llvmorg-$_llvm_ver/compiler-rt-$_llvm_ver.src.tar.xz.sig"
+sha256sums[2]="6a7da64d3a0a7320577b68b9ca4933bdcab676e898b759850e827333c3282c75"