summaryrefslogtreecommitdiff
path: root/extra/qt5-webengine
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-05-19 12:14:41 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-05-19 12:14:41 +0200
commitb47f38d0ae7eceef8f1c8a37f6384e478c292eb5 (patch)
tree77a6cb7da87cea148ff9459ac9373facddd88959 /extra/qt5-webengine
parent9428209822a8f0ef0f20b6117c9144635c849821 (diff)
downloadpackages-b47f38d0ae7eceef8f1c8a37f6384e478c292eb5.tar.xz
extra/qt5-webengine: remove seccomp and gcc10 cstdint patching (is fixed upstream)
Diffstat (limited to 'extra/qt5-webengine')
-rw-r--r--extra/qt5-webengine/PKGBUILD28
-rw-r--r--extra/qt5-webengine/qtwebengine-everywhere-src-5.15.0-gcc10-patches.patch10
-rw-r--r--extra/qt5-webengine/qtwebengine-everywhere-src-5.15.0-sandbox-Aw-snap-for-syscalls-403-and-407.patch85
3 files changed, 0 insertions, 123 deletions
diff --git a/extra/qt5-webengine/PKGBUILD b/extra/qt5-webengine/PKGBUILD
index 012f2d35..a3e2bbd3 100644
--- a/extra/qt5-webengine/PKGBUILD
+++ b/extra/qt5-webengine/PKGBUILD
@@ -23,34 +23,6 @@ eval "$(
'
)"
-# redone patch, see also https://bugs.gentoo.org/721876
-# most is now fixed upstream in 5.15.0, patch for
-# src/3rdparty/chromium/third_party/webrtc/modules/video_coding/decoding_state.h
-# might be superfluous, but testing takes too much time, so keeping it for now.
-# (IMHO it would include cstdint just by accident, the header file need uintxx_t)
-source+=('qtwebengine-everywhere-src-5.15.0-gcc10-patches.patch')
-sha256sums+=('b41d4eca4c75c6d8115444ac4b10b8aa0f742d3ce64077d77eb4fb2079d0a42c')
-
-eval "$(
- declare -f prepare | \
- sed '
- $ i cd "$srcdir/${_pkgfqn}"; patch -Np1 -i "${srcdir}"/qtwebengine-everywhere-src-5.15.0-gcc10-patches.patch
- '
-)"
-
-# backport seccomp time function jail fix from chromium
-# for for 64-bit time functions in seccomp sanbox (thanks to schnitzeltony)
-# https://github.com/schnitzeltony/meta-browser/blob/master/recipes-browser/chromium/files/0003-Fix-sandbox-Aw-snap-for-syscalls-403-and-407.patch
-source+=('qtwebengine-everywhere-src-5.15.0-sandbox-Aw-snap-for-syscalls-403-and-407.patch')
-sha256sums+=('606adb05a5bc903ac371e8040a4c2b06847d32de72be8b15949a161946aa826c')
-
-eval "$(
- declare -f prepare | \
- sed '
- $ i cd "$srcdir/${_pkgfqn}"; patch -Np1 -i "${srcdir}"/qtwebengine-everywhere-src-5.15.0-sandbox-Aw-snap-for-syscalls-403-and-407.patch
- '
-)"
-
# glibc 2.33, some more tim64-affected functions for seccomp (futex_time64,
# pselect6_time64), also added missing network functions for __i386__ and missing statx
# (see also FS32#162)
diff --git a/extra/qt5-webengine/qtwebengine-everywhere-src-5.15.0-gcc10-patches.patch b/extra/qt5-webengine/qtwebengine-everywhere-src-5.15.0-gcc10-patches.patch
deleted file mode 100644
index 2db3d074..00000000
--- a/extra/qt5-webengine/qtwebengine-everywhere-src-5.15.0-gcc10-patches.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- qtwebengine-everywhere-src-5.15.0/src/3rdparty/chromium/third_party/webrtc/modules/video_coding/decoding_state.h 2020-05-06 16:21:29.000000000 +0200
-+++ qtwebengine-everywhere-src-5.15.0-gcc10-patches-patch/src/3rdparty/chromium/third_party/webrtc/modules/video_coding/decoding_state.h 2020-06-04 12:07:20.407353742 +0200
-@@ -13,6 +13,7 @@
-
- #include <map>
- #include <set>
-+#include <cstdint>
- #include <vector>
-
- namespace webrtc {
diff --git a/extra/qt5-webengine/qtwebengine-everywhere-src-5.15.0-sandbox-Aw-snap-for-syscalls-403-and-407.patch b/extra/qt5-webengine/qtwebengine-everywhere-src-5.15.0-sandbox-Aw-snap-for-syscalls-403-and-407.patch
deleted file mode 100644
index f9211305..00000000
--- a/extra/qt5-webengine/qtwebengine-everywhere-src-5.15.0-sandbox-Aw-snap-for-syscalls-403-and-407.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-diff -rauN qtwebengine-everywhere-src-5.15.0/src/3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/baseline_policy.cc qtwebengine-everywhere-src-5.15.0-sandbox-Aw-snap-for-syscalls-403-and-407-patch/src/3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/baseline_policy.cc
---- qtwebengine-everywhere-src-5.15.0/src/3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/baseline_policy.cc 2020-05-06 16:21:29.000000000 +0200
-+++ qtwebengine-everywhere-src-5.15.0-sandbox-Aw-snap-for-syscalls-403-and-407-patch/src/3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/baseline_policy.cc 2020-08-16 08:55:45.992315648 +0200
-@@ -148,7 +148,14 @@
- return Allow();
- #endif
-
-- if (sysno == __NR_clock_gettime || sysno == __NR_clock_nanosleep) {
-+ if (sysno == __NR_clock_gettime || sysno == __NR_clock_nanosleep
-+#if defined(__NR_clock_gettime64)
-+ || sysno == __NR_clock_gettime64
-+#endif
-+#if defined(__NR_clock_nanosleep_time64)
-+ || sysno == __NR_clock_nanosleep_time64
-+#endif
-+ ) {
- return RestrictClockID();
- }
-
-diff -rauN qtwebengine-everywhere-src-5.15.0/src/3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_parameters_restrictions_unittests.cc qtwebengine-everywhere-src-5.15.0-sandbox-Aw-snap-for-syscalls-403-and-407-patch/src/3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_parameters_restrictions_unittests.cc
---- qtwebengine-everywhere-src-5.15.0/src/3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_parameters_restrictions_unittests.cc 2020-05-06 16:21:29.000000000 +0200
-+++ qtwebengine-everywhere-src-5.15.0-sandbox-Aw-snap-for-syscalls-403-and-407-patch/src/3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_parameters_restrictions_unittests.cc 2020-08-16 08:56:28.085606998 +0200
-@@ -60,6 +60,12 @@
- case __NR_clock_gettime:
- case __NR_clock_getres:
- case __NR_clock_nanosleep:
-+#if defined(__NR_clock_nanosleep_time64)
-+ case __NR_clock_nanosleep_time64:
-+#endif
-+#if defined(__NR_clock_gettime64)
-+ case __NR_clock_gettime64:
-+#endif
- return RestrictClockID();
- default:
- return Allow();
-diff -rauN qtwebengine-everywhere-src-5.15.0/src/3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_sets.cc qtwebengine-everywhere-src-5.15.0-sandbox-Aw-snap-for-syscalls-403-and-407-patch/src/3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_sets.cc
---- qtwebengine-everywhere-src-5.15.0/src/3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_sets.cc 2020-05-06 16:21:29.000000000 +0200
-+++ qtwebengine-everywhere-src-5.15.0-sandbox-Aw-snap-for-syscalls-403-and-407-patch/src/3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_sets.cc 2020-08-16 08:57:06.615551750 +0200
-@@ -39,6 +39,12 @@
- // filtered by RestrictClokID().
- case __NR_clock_gettime: // Parameters filtered by RestrictClockID().
- case __NR_clock_nanosleep: // Parameters filtered by RestrictClockID().
-+#if defined(__NR_clock_gettime64)
-+ case __NR_clock_gettime64: // Parameters filtered by RestrictClockID().
-+#endif
-+#if defined(__NR_clock_nanosleep_time64)
-+ case __NR_clock_nanosleep_time64: // Parameters filtered by RestrictClockID().
-+#endif
- case __NR_clock_settime: // Privileged.
- #if defined(__i386__) || \
- (defined(ARCH_CPU_MIPS_FAMILY) && defined(ARCH_CPU_32_BITS))
-diff -rauN qtwebengine-everywhere-src-5.15.0/src/3rdparty/chromium/sandbox/linux/system_headers/arm_linux_syscalls.h qtwebengine-everywhere-src-5.15.0-sandbox-Aw-snap-for-syscalls-403-and-407-patch/src/3rdparty/chromium/sandbox/linux/system_headers/arm_linux_syscalls.h
---- qtwebengine-everywhere-src-5.15.0/src/3rdparty/chromium/sandbox/linux/system_headers/arm_linux_syscalls.h 2020-05-06 16:21:29.000000000 +0200
-+++ qtwebengine-everywhere-src-5.15.0-sandbox-Aw-snap-for-syscalls-403-and-407-patch/src/3rdparty/chromium/sandbox/linux/system_headers/arm_linux_syscalls.h 2020-08-16 08:57:56.025481868 +0200
-@@ -1385,6 +1385,14 @@
- #define __NR_memfd_create (__NR_SYSCALL_BASE+385)
- #endif
-
-+#if !defined(__NR_clock_gettime64)
-+#define __NR_clock_gettime64 (__NR_SYSCALL_BASE+403)
-+#endif
-+
-+#if !defined(__NR_clock_nanosleep_time64)
-+#define __NR_clock_nanosleep_time64 (__NR_SYSCALL_BASE+407)
-+#endif
-+
- // ARM private syscalls.
- #if !defined(__ARM_NR_BASE)
- #define __ARM_NR_BASE (__NR_SYSCALL_BASE + 0xF0000)
-diff -rauN qtwebengine-everywhere-src-5.15.0/src/3rdparty/chromium/sandbox/linux/system_headers/mips_linux_syscalls.h qtwebengine-everywhere-src-5.15.0-sandbox-Aw-snap-for-syscalls-403-and-407-patch/src/3rdparty/chromium/sandbox/linux/system_headers/mips_linux_syscalls.h
---- qtwebengine-everywhere-src-5.15.0/src/3rdparty/chromium/sandbox/linux/system_headers/mips_linux_syscalls.h 2020-05-06 16:21:29.000000000 +0200
-+++ qtwebengine-everywhere-src-5.15.0-sandbox-Aw-snap-for-syscalls-403-and-407-patch/src/3rdparty/chromium/sandbox/linux/system_headers/mips_linux_syscalls.h 2020-08-16 08:58:27.458771331 +0200
-@@ -1433,4 +1433,12 @@
- #define __NR_memfd_create (__NR_Linux + 354)
- #endif
-
-+#if !defined(__NR_clock_gettime64)
-+#define __NR_clock_gettime64 (__NR_Linux + 403)
-+#endif
-+
-+#if !defined(__NR_clock_nanosleep_time64)
-+#define __NR_clock_nanosleep_time64 (__NR_Linux + 407)
-+#endif
-+
- #endif // SANDBOX_LINUX_SYSTEM_HEADERS_MIPS_LINUX_SYSCALLS_H_