summaryrefslogtreecommitdiff
path: root/extra/qt5-base
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-05-04 17:58:11 +0000
committerAndreas Baumann <mail@andreasbaumann.cc>2019-05-04 17:58:11 +0000
commit9f709a9e5992b03bdef7ea66442ea420ee3a164b (patch)
tree50c216aefdf0415b65b9fd2679529d5017ecdc35 /extra/qt5-base
parent9a190a9e003ae1c2da5162ac275db5362b6dd66a (diff)
downloadpackages-9f709a9e5992b03bdef7ea66442ea420ee3a164b.tar.xz
extra/qt5-base: no sse2 for i486/i686, but sse2 for pentium4
Diffstat (limited to 'extra/qt5-base')
-rw-r--r--extra/qt5-base/PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/extra/qt5-base/PKGBUILD b/extra/qt5-base/PKGBUILD
index 4507cf9e..8b08f917 100644
--- a/extra/qt5-base/PKGBUILD
+++ b/extra/qt5-base/PKGBUILD
@@ -1,9 +1,11 @@
-eval "$(
- declare -f build | \
- sed '
- s@./configure@./configure -no-sse2@g
- '
-)"
+if [ "$CARCH" = 'i486' -o "$CARCH" = 'i686' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s@./configure@./configure -no-sse2@g
+ '
+ )"
+fi
makedepends=(${makedepends[@]/vulkan-headers/})
makedepends_i686+=(vulkan-headers)