summaryrefslogtreecommitdiff
path: root/extra/qt5-base/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-04-15 10:31:58 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-04-15 10:31:58 +0200
commit5bcf9766eba3d7f9569826614578971030f62d97 (patch)
treec319189375057ea193fc3528a1b150e02ac0c609 /extra/qt5-base/PKGBUILD
parentc8a8b78f3ea5327c286ab0a9daa8ef01bf2dc004 (diff)
downloadpackages-5bcf9766eba3d7f9569826614578971030f62d97.tar.xz
extra/qt5-base: added explicit -xcb for i486
Diffstat (limited to 'extra/qt5-base/PKGBUILD')
-rw-r--r--extra/qt5-base/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/extra/qt5-base/PKGBUILD b/extra/qt5-base/PKGBUILD
index 6df4ee22..0934cf81 100644
--- a/extra/qt5-base/PKGBUILD
+++ b/extra/qt5-base/PKGBUILD
@@ -17,3 +17,14 @@ if [ "$CARCH" = 'i486' ]; then
'
)"
fi
+
+# enable XCB explicitely for now on i486 (rather fail early than to
+# get weird startup messages of Qt5 applications hours later)
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/configure/configure -xcb /
+ '
+ )"
+fi