summaryrefslogtreecommitdiff
path: root/extra/nasm
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-16 16:21:14 +0100
committerErich Eckner <git@eckner.net>2019-01-16 16:21:14 +0100
commit279979eeb6b78cbc23b1f0358c1933188ae84044 (patch)
tree6a733abd04d069083cce0153c7008613dabe2adb /extra/nasm
parent3e59b8e562bd079d66188ed6ce66478639a00413 (diff)
downloadpackages-279979eeb6b78cbc23b1f0358c1933188ae84044.tar.xz
extra/nasm: remove obsolete patch
Diffstat (limited to 'extra/nasm')
-rw-r--r--extra/nasm/0001-Remove-invalid-pure_func-qualifiers.patch27
-rw-r--r--extra/nasm/PKGBUILD8
2 files changed, 0 insertions, 35 deletions
diff --git a/extra/nasm/0001-Remove-invalid-pure_func-qualifiers.patch b/extra/nasm/0001-Remove-invalid-pure_func-qualifiers.patch
deleted file mode 100644
index 87ec601c..00000000
--- a/extra/nasm/0001-Remove-invalid-pure_func-qualifiers.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From d0dabb46a821b2506681f882af0d5696d2c2bade Mon Sep 17 00:00:00 2001
-From: Michael Simacek <msimacek@redhat.com>
-Date: Thu, 8 Feb 2018 14:47:08 +0100
-Subject: [PATCH] Remove invalid pure_func qualifiers
-
----
- include/nasmlib.h | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/include/nasmlib.h b/include/nasmlib.h
-index 79e866b..c93cef0 100644
---- a/include/nasmlib.h
-+++ b/include/nasmlib.h
-@@ -191,8 +191,8 @@ int64_t readstrnum(char *str, int length, bool *warn);
- * seg_init: Initialise the segment-number allocator.
- * seg_alloc: allocate a hitherto unused segment number.
- */
--void pure_func seg_init(void);
--int32_t pure_func seg_alloc(void);
-+void seg_init(void);
-+int32_t seg_alloc(void);
-
- /*
- * many output formats will be able to make use of this: a standard
---
-2.14.3
-
diff --git a/extra/nasm/PKGBUILD b/extra/nasm/PKGBUILD
index 7af19efd..f1a34d1a 100644
--- a/extra/nasm/PKGBUILD
+++ b/extra/nasm/PKGBUILD
@@ -1,11 +1,3 @@
-# see FS#60380
-source+=('0001-Remove-invalid-pure_func-qualifiers.patch')
-sha512sums+=('3bf974c067d16144d1457c0ef4d63bab511e6949923338cc7555169b297617ed0ec3de5825faf85afd5da735aa46f7d2e603319badead7e8bc1f6a4d58f1bd2d')
-prepare() {
- cd $pkgname-$pkgver
- patch -Np1 -i "$srcdir/0001-Remove-invalid-pure_func-qualifiers.patch"
-}
-
# remove ttf-liberation on i486 (X packages missing for installing the font)
makedepends=(${makedepends[@]//ttf-liberation/})
makedepends_i686+=(ttf-liberation)