summaryrefslogtreecommitdiff
path: root/extra/nasm/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2018-11-09 13:53:18 +0100
committerErich Eckner <git@eckner.net>2018-11-09 13:53:18 +0100
commitbcb5133554da96e552b4d74fe48d336a80efebed (patch)
treed8a32204cde75836563f405691c83fc21f1fa95a /extra/nasm/PKGBUILD
parent15cb4dca227b2a7873adc64350601dde8d85f985 (diff)
downloadpackages-bcb5133554da96e552b4d74fe48d336a80efebed.tar.xz
"if [ $CARCH = ... ]; then depends=..; fi" => "depends_...=..."
Diffstat (limited to 'extra/nasm/PKGBUILD')
-rw-r--r--extra/nasm/PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/extra/nasm/PKGBUILD b/extra/nasm/PKGBUILD
index 36e81008..6e1fab99 100644
--- a/extra/nasm/PKGBUILD
+++ b/extra/nasm/PKGBUILD
@@ -6,11 +6,13 @@ prepare() {
patch -Np1 -i "$srcdir/0001-Remove-invalid-pure_func-qualifiers.patch"
}
+# remove ttf-liberation on i486 (X packages missing for installing the font)
+makedepends=(${makedepends[@]//ttf-liberation/})
+makedepends_i686+=(ttf-liberation)
+
# i486-specific
if [ "${CARCH}" = "i486" ]; then
# remove ttf-liberation (X packages missing for installing the font)
- makedepends=(${makedepends[@]//ttf-liberation/})
-
eval "$(
declare -f build | \
sed "