summaryrefslogtreecommitdiff
path: root/extra/mariadb
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-05-30 15:38:21 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-05-30 15:38:21 +0200
commit9cffff411e28e91f015a5a7079844d501697c097 (patch)
treeefb962277762648cc7268ca88fac2d72092a08bc /extra/mariadb
parentc3f54609d02c10761ccf020d6b12994d4359c286 (diff)
downloadpackages-9cffff411e28e91f015a5a7079844d501697c097.tar.xz
extra/mariadb: applying atomic patch on i486 only
Diffstat (limited to 'extra/mariadb')
-rw-r--r--extra/mariadb/PKGBUILD37
1 files changed, 12 insertions, 25 deletions
diff --git a/extra/mariadb/PKGBUILD b/extra/mariadb/PKGBUILD
index 83ea7950..f9ff5654 100644
--- a/extra/mariadb/PKGBUILD
+++ b/extra/mariadb/PKGBUILD
@@ -1,25 +1,12 @@
-# add -latomic where needed
-# e.g.TARGET_LINK_LIBRARIES(mariabackup sql crc atomic)
-source+=('mariadb-10.5.10-atomic.patch')
-sha256sums+=('b235236c9a872a4921e5c6e57dbcc75e52d544ddd6ed4ac84ebd627853207b15')
-eval "$(
- declare -f prepare | \
- sed '
- /patch -Np1.*0001-arch-specific.patch/ a \ patch -Np1 -i "${srcdir}/mariadb-10.5.10-atomic.patch"
- '
-)"
-
-# tests are also disabled upstream, running them manually on i486 looks ok
-#The servers were restarted 1548 times
-#Spent 5008.297 of 859 seconds executing testcases
-#
-#Completed: Failed 5/5417 tests, 99.91% were successful.
-#
-#Failing test(s): main.mysqldump main.ddl_i18n_koi8r main.ddl_i18n_utf8 main.flush_logs_not_windows perfschema.bad_option
-#
-#The log files in var/log may give you some hint of what went wrong.
-#
-#If you want to report this error, please read first the documentation
-#at http://dev.mysql.com/doc/mysql/en/mysql-test-suite.html
-#
-#962 tests were skipped, 293 by the test itself.
+# add -latomic where needed (i486)
+# patch mainly from VoidLinux, applying on i486 as it seems to fail on i686 and pentium4
+if [ "$CARCH" = 'i486' ]; then
+ source+=('mariadb-10.5.10-atomic.patch')
+ sha256sums+=('b235236c9a872a4921e5c6e57dbcc75e52d544ddd6ed4ac84ebd627853207b15')
+ eval "$(
+ declare -f prepare | \
+ sed '
+ /patch -Np1.*0001-arch-specific.patch/ a \ patch -Np1 -i "${srcdir}/mariadb-10.5.10-atomic.patch"
+ '
+ )"
+fi