summaryrefslogtreecommitdiff
path: root/extra/linux-zen/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-04-30 20:22:06 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-04-30 20:22:06 +0200
commitf6636f6979f77d9ffe8c836d8681678993a94db4 (patch)
tree40331fa39800535bd4dec22e255caafe322bb930 /extra/linux-zen/PKGBUILD
parent84bc75c330fe68d0293ed7ea9525bb13011b1f1c (diff)
downloadpackages-f6636f6979f77d9ffe8c836d8681678993a94db4.tar.xz
extra/linux-zen: disabled archive-server
Diffstat (limited to 'extra/linux-zen/PKGBUILD')
-rw-r--r--extra/linux-zen/PKGBUILD116
1 files changed, 58 insertions, 58 deletions
diff --git a/extra/linux-zen/PKGBUILD b/extra/linux-zen/PKGBUILD
index 59216254..a5a65803 100644
--- a/extra/linux-zen/PKGBUILD
+++ b/extra/linux-zen/PKGBUILD
@@ -19,65 +19,65 @@ eval "$(
)"
# use our tarballer instead of cloning from git
-for ((i=0; i<${#source[@]}; i++)); do
- infos=$(
- printf '%s\n' "${source[${i}]}" | \
- sed '
- s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=[^?]\+\)$@\3 \2 \4 \5 \6@
- t
- s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)#\(\(tag\|commit\)=[^?]\+\)\(?signed\)\?$@\3 \2 \4 \7 \5@
- t
- d
- '
- )
- if [ -n "${infos}" ]; then
- source[${i}]=$(
- type="${infos%% *}"
- infos="${infos#* }"
- if [ -n "${infos%% *}" ]; then
- prefix="${infos%% *}"
- else
- prefix=''
- fi
- infos="${infos#* }"
- repo="${infos%% *}"
- repo64=$(
- printf '%s' "${repo}" | \
- base64 -w0 | \
- sed 's/=/%3D/g'
- )
- infos="${infos#* }"
- if [ "${infos%% *}" = '?signed' ]; then
- key_check=$(
- printf '&valid_keys='
- printf '%s,' "${validpgpkeys[@]}" | \
- sed 's/,$//'
- )
- else
- key_check=''
- fi
- infos="${infos#* }"
- if [ -z "${prefix}" ]; then
- prefix="${repo%.git}"
- prefix="${prefix##*/}"
- fi
- prefix_64=$(
- printf '%s/' "${prefix}" | \
- base64 -w0 | \
- sed 's/=/%3D/g'
- )
+#~ for ((i=0; i<${#source[@]}; i++)); do
+ #~ infos=$(
+ #~ printf '%s\n' "${source[${i}]}" | \
+ #~ sed '
+ #~ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=[^?]\+\)$@\3 \2 \4 \5 \6@
+ #~ t
+ #~ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)#\(\(tag\|commit\)=[^?]\+\)\(?signed\)\?$@\3 \2 \4 \7 \5@
+ #~ t
+ #~ d
+ #~ '
+ #~ )
+ #~ if [ -n "${infos}" ]; then
+ #~ source[${i}]=$(
+ #~ type="${infos%% *}"
+ #~ infos="${infos#* }"
+ #~ if [ -n "${infos%% *}" ]; then
+ #~ prefix="${infos%% *}"
+ #~ else
+ #~ prefix=''
+ #~ fi
+ #~ infos="${infos#* }"
+ #~ repo="${infos%% *}"
+ #~ repo64=$(
+ #~ printf '%s' "${repo}" | \
+ #~ base64 -w0 | \
+ #~ sed 's/=/%3D/g'
+ #~ )
+ #~ infos="${infos#* }"
+ #~ if [ "${infos%% *}" = '?signed' ]; then
+ #~ key_check=$(
+ #~ printf '&valid_keys='
+ #~ printf '%s,' "${validpgpkeys[@]}" | \
+ #~ sed 's/,$//'
+ #~ )
+ #~ else
+ #~ key_check=''
+ #~ fi
+ #~ infos="${infos#* }"
+ #~ if [ -z "${prefix}" ]; then
+ #~ prefix="${repo%.git}"
+ #~ prefix="${prefix##*/}"
+ #~ fi
+ #~ prefix_64=$(
+ #~ printf '%s/' "${prefix}" | \
+ #~ base64 -w0 | \
+ #~ sed 's/=/%3D/g'
+ #~ )
- printf '%s-%s.tar.gz::https://archive-server.archlinux32.org/?t=%s&p=%s&r=%s%s&%s\n' \
- "${prefix}" \
- "${pkgver}" \
- "${type}" \
- "${prefix_64}" \
- "${repo64}" \
- "${key_check}" \
- "${infos}"
- )
- fi
-done
+ #~ printf '%s-%s.tar.gz::https://archive-server.archlinux32.org/?t=%s&p=%s&r=%s%s&%s\n' \
+ #~ "${prefix}" \
+ #~ "${pkgver}" \
+ #~ "${type}" \
+ #~ "${prefix_64}" \
+ #~ "${repo64}" \
+ #~ "${key_check}" \
+ #~ "${infos}"
+ #~ )
+ #~ fi
+#~ done
# temporary (FS32#163)
eval "$(