summaryrefslogtreecommitdiff
path: root/extra/linux-olpc-xo1/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-04-30 20:21:57 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-04-30 20:21:57 +0200
commit84bc75c330fe68d0293ed7ea9525bb13011b1f1c (patch)
tree9d533b3a65fd9ba1bcf86c76c093a0a7f0f5709a /extra/linux-olpc-xo1/PKGBUILD
parenta68c68ebd7e208aea68a9e140d115fddacc23168 (diff)
downloadpackages-84bc75c330fe68d0293ed7ea9525bb13011b1f1c.tar.xz
extra/linux-olpc-xo1: disabled archive-server
Diffstat (limited to 'extra/linux-olpc-xo1/PKGBUILD')
-rw-r--r--extra/linux-olpc-xo1/PKGBUILD118
1 files changed, 59 insertions, 59 deletions
diff --git a/extra/linux-olpc-xo1/PKGBUILD b/extra/linux-olpc-xo1/PKGBUILD
index 2aa89bb0..d114eeb1 100644
--- a/extra/linux-olpc-xo1/PKGBUILD
+++ b/extra/linux-olpc-xo1/PKGBUILD
@@ -193,62 +193,62 @@ for _p in "${pkgname[@]}"; do
done
# use our tarballer instead of cloning from git
-for ((i=0; i<${#source[@]}; i++)); do
- infos=$(
- printf '%s\n' "${source[${i}]}" | \
- sed '
- s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=[^?]\+\)$@\3 \2 \4 \5 \6@
- t
- s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)#\(\(tag\|commit\)=[^?]\+\)\(?signed\)\?$@\3 \2 \4 \7 \5@
- t
- d
- '
- )
- if [ -n "${infos}" ]; then
- source[${i}]=$(
- type="${infos%% *}"
- infos="${infos#* }"
- if [ -n "${infos%% *}" ]; then
- prefix="${infos%% *}"
- else
- prefix=''
- fi
- infos="${infos#* }"
- repo="${infos%% *}"
- repo64=$(
- printf '%s' "${repo}" | \
- base64 -w0 | \
- sed 's/=/%3D/g'
- )
- infos="${infos#* }"
- if [ "${infos%% *}" = '?signed' ]; then
- key_check=$(
- printf '&valid_keys='
- printf '%s,' "${validpgpkeys[@]}" | \
- sed 's/,$//'
- )
- else
- key_check=''
- fi
- infos="${infos#* }"
- if [ -z "${prefix}" ]; then
- prefix="${repo%.git}"
- prefix="${prefix##*/}"
- fi
- prefix_64=$(
- printf '%s/' "${prefix}" | \
- base64 -w0 | \
- sed 's/=/%3D/g'
- )
-
- printf '%s-%s.tar.gz::https://archive-server.archlinux32.org/?t=%s&p=%s&r=%s%s&%s\n' \
- "${prefix}" \
- "${pkgver}" \
- "${type}" \
- "${prefix_64}" \
- "${repo64}" \
- "${key_check}" \
- "${infos}"
- )
- fi
-done
+#~ for ((i=0; i<${#source[@]}; i++)); do
+ #~ infos=$(
+ #~ printf '%s\n' "${source[${i}]}" | \
+ #~ sed '
+ #~ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=[^?]\+\)$@\3 \2 \4 \5 \6@
+ #~ t
+ #~ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)#\(\(tag\|commit\)=[^?]\+\)\(?signed\)\?$@\3 \2 \4 \7 \5@
+ #~ t
+ #~ d
+ #~ '
+ #~ )
+ #~ if [ -n "${infos}" ]; then
+ #~ source[${i}]=$(
+ #~ type="${infos%% *}"
+ #~ infos="${infos#* }"
+ #~ if [ -n "${infos%% *}" ]; then
+ #~ prefix="${infos%% *}"
+ #~ else
+ #~ prefix=''
+ #~ fi
+ #~ infos="${infos#* }"
+ #~ repo="${infos%% *}"
+ #~ repo64=$(
+ #~ printf '%s' "${repo}" | \
+ #~ base64 -w0 | \
+ #~ sed 's/=/%3D/g'
+ #~ )
+ #~ infos="${infos#* }"
+ #~ if [ "${infos%% *}" = '?signed' ]; then
+ #~ key_check=$(
+ #~ printf '&valid_keys='
+ #~ printf '%s,' "${validpgpkeys[@]}" | \
+ #~ sed 's/,$//'
+ #~ )
+ #~ else
+ #~ key_check=''
+ #~ fi
+ #~ infos="${infos#* }"
+ #~ if [ -z "${prefix}" ]; then
+ #~ prefix="${repo%.git}"
+ #~ prefix="${prefix##*/}"
+ #~ fi
+ #~ prefix_64=$(
+ #~ printf '%s/' "${prefix}" | \
+ #~ base64 -w0 | \
+ #~ sed 's/=/%3D/g'
+ #~ )
+
+ #~ printf '%s-%s.tar.gz::https://archive-server.archlinux32.org/?t=%s&p=%s&r=%s%s&%s\n' \
+ #~ "${prefix}" \
+ #~ "${pkgver}" \
+ #~ "${type}" \
+ #~ "${prefix_64}" \
+ #~ "${repo64}" \
+ #~ "${key_check}" \
+ #~ "${infos}"
+ #~ )
+ #~ fi
+#~ done