summaryrefslogtreecommitdiff
path: root/extra/libreoffice-still/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-04-25 18:18:51 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-04-25 18:18:51 +0200
commit1018a0b47baaef7f154b5e5213ad0edfe01ab8ba (patch)
tree90f96e7d18c018bc6a12a24af19a20778bd0de55 /extra/libreoffice-still/PKGBUILD
parent3a287a4a98183c6506d8497b76e26aa22c05891b (diff)
downloadpackages-1018a0b47baaef7f154b5e5213ad0edfe01ab8ba.tar.xz
extra/libreoffice-*: tried to build i486
Diffstat (limited to 'extra/libreoffice-still/PKGBUILD')
-rw-r--r--extra/libreoffice-still/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/extra/libreoffice-still/PKGBUILD b/extra/libreoffice-still/PKGBUILD
index 0f0d9e65..66998621 100644
--- a/extra/libreoffice-still/PKGBUILD
+++ b/extra/libreoffice-still/PKGBUILD
@@ -7,3 +7,26 @@ eval "$(
s|--enable-ext-nlpsolver|--disable-ext-nlpsolver|
'
)"
+
+# no coin-ormp on i486 (for now, suitesparse has atomic issues)
+if [ "$CARCH" = 'i486' ]; then
+ makedepends=(${makedepends[@]//coin-or-mp/})
+fi
+
+# ignore mariadb on i486 (for now)
+if [ "$CARCH" = 'i486' ]; then
+ makedepends=(${makedepends[@]//mariadb-libs/})
+fi
+
+# Java currently broken on i486
+if [ "$CARCH" = 'i486' ]; then
+ makedepends=(${makedepends[@]//java-environment=11/})
+ makedepends=(${makedepends[@]//ant/})
+ makedepends=(${makedepends[@]//junit/})
+ makedepends=(${makedepends[@]//beanshell/})
+fi
+
+# no KDE/Plasma on i486
+if [ "$CARCH" = 'i486' ]; then
+ makedepends=(${makedepends[@]//plasma-framework/})
+fi