summaryrefslogtreecommitdiff
path: root/extra/grantlee
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-08-25 10:40:22 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-08-25 10:40:22 +0200
commitaed7093a8708a0c00c131e842a7d3dd39428416a (patch)
tree8222bdf07f32ec1348b4387f8ab873378c580de4 /extra/grantlee
parentc7191a0f0247cd17d5371fbb35d2f1a315c38e03 (diff)
downloadpackages-aed7093a8708a0c00c131e842a7d3dd39428416a.tar.xz
extra/grantlee: ported patches from FS#63552
Diffstat (limited to 'extra/grantlee')
-rw-r--r--extra/grantlee/PKGBUILD15
-rw-r--r--extra/grantlee/grantlee-c++11.patch24
-rw-r--r--extra/grantlee/grantlee-qt-5.13.patch27
3 files changed, 66 insertions, 0 deletions
diff --git a/extra/grantlee/PKGBUILD b/extra/grantlee/PKGBUILD
new file mode 100644
index 00000000..70e81152
--- /dev/null
+++ b/extra/grantlee/PKGBUILD
@@ -0,0 +1,15 @@
+# forward port from see FS#63552
+
+source+=(grantlee-c++11.patch grantlee-qt-5.13.patch)
+sha256sums+=('a14257e61489ee46c9236cc21af06e0eee5084c1563992d5a470153c7f318999'
+ '60226562926c881cc617f236936d611a85e841865095e215f0f470d1eb945b77')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ 3 a \
+ cd $pkgname-$pkgver \
+ patch -p1 -i ../grantlee-c++11.patch # Fix build with new gcc/Qt combinations \
+ patch -p1 -i ../grantlee-qt-5.13.patch # Fix build with Qt 5.13
+ '
+)"
diff --git a/extra/grantlee/grantlee-c++11.patch b/extra/grantlee/grantlee-c++11.patch
new file mode 100644
index 00000000..d049d6c9
--- /dev/null
+++ b/extra/grantlee/grantlee-c++11.patch
@@ -0,0 +1,24 @@
+From 3a5fc7662da3261be6496611900c095844e56ab1 Mon Sep 17 00:00:00 2001
+From: Albert Astals Cid <aacid@kde.org>
+Date: Sat, 20 Jul 2019 17:35:30 +0200
+Subject: [PATCH] Fix compile with newer Qt/cmake combination
+
+Without this i get huge errors about Qt needing C++11 support
+---
+ CMakeLists.txt | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 6d51110..0859788 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -11,6 +11,9 @@ endif()
+
+ project(Grantlee)
+
++set (CMAKE_CXX_STANDARD 11)
++set (CMAKE_CXX_EXTENSIONS OFF)
++
+ # Workaround for http://public.kitware.com/Bug/view.php?id=12301
+ if (MINGW)
+ if(NOT CMAKE_BUILD_TYPE)
diff --git a/extra/grantlee/grantlee-qt-5.13.patch b/extra/grantlee/grantlee-qt-5.13.patch
new file mode 100644
index 00000000..67a92c1f
--- /dev/null
+++ b/extra/grantlee/grantlee-qt-5.13.patch
@@ -0,0 +1,27 @@
+From 0cee029ee03ab4906c6d19b57458b5036852b0f8 Mon Sep 17 00:00:00 2001
+From: Michael Pyne <mpyne@kde.org>
+Date: Tue, 18 Dec 2018 17:47:21 -0500
+Subject: [PATCH] Fix build with Qt 5.13 / GCC 8.2.
+
+At this point Grantlee doesn't build for me because QList is an
+incomplete type. I think the compiler is right to complain, so I fix by
+including the appropriate header.
+
+Fixes issue #47.
+---
+ templates/lib/lexer_p.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/templates/lib/lexer_p.h b/templates/lib/lexer_p.h
+index 275aeea..1ae451a 100644
+--- a/templates/lib/lexer_p.h
++++ b/templates/lib/lexer_p.h
+@@ -24,7 +24,7 @@
+ #include "textprocessingmachine_p.h"
+ #include "token.h"
+
+-template <typename T> class QList;
++#include <QList>
+
+ namespace Grantlee
+ {