summaryrefslogtreecommitdiff
path: root/extra/firefox
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-10-25 16:06:23 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-10-25 16:06:23 +0200
commitda1fb27fe6d16fb1fa3017f95527862697630ca4 (patch)
treebccab5106756244332b77f5dd3213c7cdd136685 /extra/firefox
parent5b58d7c64badaec49e8d965b0c848afa27ac90f2 (diff)
downloadpackages-da1fb27fe6d16fb1fa3017f95527862697630ca4.tar.xz
extra/firefox: disable C++/Rust PGO as gcc doesnt support that
Diffstat (limited to 'extra/firefox')
-rw-r--r--extra/firefox/PKGBUILD2
-rw-r--r--extra/firefox/mozconfig.patch11
2 files changed, 10 insertions, 3 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 6a2bd9ff..a76ae2ac 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -96,7 +96,7 @@ eval "$(
# test failure in rust code (complaining about network functions) when PGO is used,
# see https://bugzilla.mozilla.org/show_bug.cgi?id=1565757
source+=('rust-static-disable-network-test-on-static-libraries.patch')
-sha256sums+=('d07e283d5c784bb44dcd0ad3f6b82f19cac562451ce07033e8dde50bf8c75d76')
+sha256sums+=('eee6f990abf166da5dba7137ccf8e8bf4aac79e1c3db1cfeec67f797609b3e59')
eval "$(
declare -f prepare | \
sed '
diff --git a/extra/firefox/mozconfig.patch b/extra/firefox/mozconfig.patch
index 88ebc50b..2363102f 100644
--- a/extra/firefox/mozconfig.patch
+++ b/extra/firefox/mozconfig.patch
@@ -1,6 +1,6 @@
diff -rauN a/mozconfig b/mozconfig
---- a/mozconfig 2019-10-25 10:25:41.779286572 +0200
-+++ b/mozconfig 2019-10-25 10:31:23.717054770 +0200
+--- a/mozconfig 2019-10-25 16:05:08.760547591 +0200
++++ b/mozconfig 2019-10-25 16:03:07.125511113 +0200
@@ -5,11 +5,12 @@
ac_add_options --enable-hardening
ac_add_options --enable-optimize
@@ -19,3 +19,10 @@ diff -rauN a/mozconfig b/mozconfig
# Branding
ac_add_options --enable-official-branding
+@@ -38,6 +39,3 @@
+ ac_add_options --disable-gconf
+ ac_add_options --disable-updater
+ ac_add_options --disable-tests
+-
+-# disable PGO
+-ac_add_options --disable-cross-pgo