summaryrefslogtreecommitdiff
path: root/extra/firefox
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2020-06-04 16:56:52 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2020-06-04 16:56:52 +0200
commit59be1606f337c3bbb18d5d0fbaf2397df0b44ddf (patch)
treebd793a3e7d5893148eaa7c0329f2d1f3fab13ab4 /extra/firefox
parentafd37e9b6ffbb80422f78f4397f84eaba18cba29 (diff)
downloadpackages-59be1606f337c3bbb18d5d0fbaf2397df0b44ddf.tar.xz
extra/firefox: redone patching for 77.0.1
Diffstat (limited to 'extra/firefox')
-rw-r--r--extra/firefox/PKGBUILD4
-rw-r--r--extra/firefox/avoid-libxul-OOM-python-check.patch29
-rw-r--r--extra/firefox/rust-static-disable-network-test-on-static-libraries.patch21
3 files changed, 33 insertions, 21 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 31c7632d..f0482553 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -125,7 +125,7 @@ eval "$(
# test failure in rust code (complaining about network functions) when PGO is used,
# see https://bugzilla.mozilla.org/show_bug.cgi?id=1565757
source+=('rust-static-disable-network-test-on-static-libraries.patch')
-sha256sums+=('7ef04324ca732df50fc33f21d8e7027c43e3c7c3a51d2332dd44853910315a67')
+sha256sums+=('3a40877475912b53c9cc443feff2ccfef71e8a0f8f45615b7959c28203a1c9a9')
eval "$(
declare -f prepare | \
sed '
@@ -145,7 +145,7 @@ eval "$(
# readelf: Error: Unable to seek to 0x801db328 for section headers
source+=('avoid-libxul-OOM-python-check.patch')
-sha256sums+=('6395b7e349963c9a689929b44525159328954af156ef0b9a42182e7e16baa8ba')
+sha256sums+=('c578c970ba0c06d70950a55f45346f4b8c3749a0da62ae4a9b87bc64d86f50c1')
eval "$(
declare -f prepare | \
sed '
diff --git a/extra/firefox/avoid-libxul-OOM-python-check.patch b/extra/firefox/avoid-libxul-OOM-python-check.patch
index 89fa3f38..4aaf550c 100644
--- a/extra/firefox/avoid-libxul-OOM-python-check.patch
+++ b/extra/firefox/avoid-libxul-OOM-python-check.patch
@@ -1,12 +1,29 @@
-diff -rauN a/config/rules.mk b/config/rules.mk
---- a/config/rules.mk 2020-04-04 12:24:34.837582901 +0200
-+++ b/config/rules.mk 2020-04-04 12:26:14.227584517 +0200
-@@ -608,7 +608,7 @@
+--- firefox-77.0.1/config/rules.mk 2020-06-03 03:04:50.000000000 +0200
++++ firefox-77.0.1-avoid-libxul-OOM-python-check-patch/config/rules.mk 2020-06-04 16:43:06.709092454 +0200
+@@ -474,7 +474,7 @@
+ endif # MSVC with manifest tool
+ else # !WINNT || GNU_CC
+ $(call EXPAND_CC_OR_CXX,$@) -o $@ $(COMPUTED_CXX_LDFLAGS) $(PGO_CFLAGS) $($(notdir $@)_OBJS) $(RESFILE) $(WIN32_EXE_LDFLAGS) $(LDFLAGS) $(STATIC_LIBS) $(MOZ_PROGRAM_LDFLAGS) $(SHARED_LIBS) $(OS_LIBS)
+- $(call py3_action,check_binary,--target $@)
++# $(call py3_action,check_binary,--target $@)
+ endif # WINNT && !GNU_CC
+
+ ifdef ENABLE_STRIP
+@@ -530,7 +530,7 @@
+ endif # MSVC with manifest tool
+ else
+ $(call EXPAND_CC_OR_CXX,$@) $(COMPUTED_CXX_LDFLAGS) $(PGO_CFLAGS) -o $@ $($@_OBJS) $(WIN32_EXE_LDFLAGS) $(LDFLAGS) $(STATIC_LIBS) $(MOZ_PROGRAM_LDFLAGS) $(SHARED_LIBS) $(OS_LIBS)
+- $(call py3_action,check_binary,--target $@)
++# $(call py3_action,check_binary,--target $@)
+ endif # WINNT && !GNU_CC
+
+ ifdef ENABLE_STRIP
+@@ -610,7 +610,7 @@
$(RM) $@
endif
$(MKSHLIB) $($@_OBJS) $(RESFILE) $(LDFLAGS) $(STATIC_LIBS) $(SHARED_LIBS) $(EXTRA_DSO_LDOPTS) $(MOZ_GLUE_LDFLAGS) $(OS_LIBS)
-- $(call py_action,check_binary,--target $@)
-+# $(call py_action,check_binary,--target $@)
+- $(call py3_action,check_binary,--target $@)
++# $(call py3_action,check_binary,--target $@)
ifeq (_WINNT,$(GNU_CC)_$(OS_ARCH))
ifdef MSMANIFEST_TOOL
diff --git a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
index 239a20dc..2ce3ce16 100644
--- a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
+++ b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
@@ -1,28 +1,23 @@
-diff -rauN firefox-74.0.1/config/makefiles/rust.mk firefox-74.0.1-rust-static-disable-network-test-on-static-libraries-patch/config/makefiles/rust.mk
---- firefox-74.0.1/config/makefiles/rust.mk 2020-04-03 13:10:23.000000000 +0200
-+++ firefox-74.0.1-rust-static-disable-network-test-on-static-libraries-patch/config/makefiles/rust.mk 2020-04-04 12:31:27.804227950 +0200
-@@ -283,17 +283,17 @@
+--- firefox-77.0.1/config/makefiles/rust.mk 2020-06-03 03:04:50.000000000 +0200
++++ firefox-77.0.1-rust-static-disable-network-test-on-static-libraries-patch/config/makefiles/rust.mk 2020-06-04 16:37:14.534723243 +0200
+@@ -299,15 +299,15 @@
# the chance of proxy bypasses originating from rust code.
# The check only works when rust code is built with -Clto.
- # Enabling sancov or TSan also causes this to fail.
+ # Sanitizers and sancov also fail because compiler-rt hooks network functions.
-ifndef MOZ_PROFILE_GENERATE
--ifndef MOZ_TSAN
-ifeq ($(OS_ARCH), Linux)
--ifeq (,$(rustflags_sancov))
+-ifeq (,$(rustflags_sancov)$(MOZ_ASAN)$(MOZ_TSAN)$(MOZ_UBSAN))
-ifneq (,$(filter -Clto,$(cargo_rustc_flags)))
-- $(call py_action,check_binary,--target --networking $@)
--endif
+- $(call py3_action,check_binary,--target --networking $@)
-endif
-endif
-endif
-endif
+#ifndef MOZ_PROFILE_GENERATE
-+#ifndef MOZ_TSAN
+#ifeq ($(OS_ARCH), Linux)
-+#ifeq (,$(rustflags_sancov))
++#ifeq (,$(rustflags_sancov)$(MOZ_ASAN)$(MOZ_TSAN)$(MOZ_UBSAN))
+#ifneq (,$(filter -Clto,$(cargo_rustc_flags)))
-+# $(call py_action,check_binary,--target --networking $@)
-+#endif
++# $(call py3_action,check_binary,--target --networking $@)
+#endif
+#endif
+#endif