summaryrefslogtreecommitdiff
path: root/extra/firefox
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-09-09 20:09:43 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-09-09 20:09:43 +0200
commit38d5e1e295c1d33e1acce27c9a1cc61c2f31d963 (patch)
treee5e55bbb76c0c72b6096526e6c39dbfb395f8d65 /extra/firefox
parentf9011cbd6630a5d9728c12bf28ef1fd9fa524530 (diff)
downloadpackages-38d5e1e295c1d33e1acce27c9a1cc61c2f31d963.tar.xz
extra/firefox: do not build symbols (FS32#174)
Diffstat (limited to 'extra/firefox')
-rw-r--r--extra/firefox/PKGBUILD15
-rw-r--r--extra/firefox/mozconfig-i686.patch10
-rw-r--r--extra/firefox/mozconfig-pentium4.patch10
3 files changed, 22 insertions, 13 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 74d7d6ff..63e84640 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -4,7 +4,7 @@
# set correct compiler and toochain tools
if [ "${CARCH}" = "pentium4" ]; then
source+=('mozconfig-pentium4.patch')
- sha256sums+=('feff56a60ab5b96982f950e5ced76516256564b68976c6cc5ed13e284d0f4b36')
+ sha256sums+=('ca75f01d9c56fff5de04395ec91b65fb87d94bc8d10acd44472d50ca8deaeda6')
eval "$(
declare -f prepare | \
sed '
@@ -14,7 +14,7 @@ eval "$(
fi
if [ "${CARCH}" = "i686" ]; then
source+=('mozconfig-i686.patch')
- sha256sums+=('06e51017d43369fefdc65a6321b07d3fd18802449b56a167767eefd5e88e65a8')
+ sha256sums+=('3de39ec7cdb2305ae635666e2909739c44d2270a8733faff90d5439c92149cdd')
eval "$(
declare -f prepare | \
sed '
@@ -201,5 +201,14 @@ fi
#zilla::dom::AccessibleNode> > >::EntryHandle>&&>’
#11:28.22 2933 | using invoke_result_t = typename invoke_result<_Fn, _Args...>::
#type;
-
makedepends+=(gcc10)
+
+# do not build and phone back symbols, fails anyway with:
+# "panic occurred at library/alloc/src/raw_vec.rs:537: capacity overflow\n" in
+# dump_syms (see also FS32#174)
+eval "$(
+ declare -f package | \
+ sed '
+ /export SOCORRO_SYMBOL_UPLOAD_TOKEN_FILE/,/fi/{s/\(.*\)/#\1/g}
+ '
+)"
diff --git a/extra/firefox/mozconfig-i686.patch b/extra/firefox/mozconfig-i686.patch
index 8d1fa667..bfe954a0 100644
--- a/extra/firefox/mozconfig-i686.patch
+++ b/extra/firefox/mozconfig-i686.patch
@@ -19,8 +19,8 @@ diff -rauN a/mozconfig b/mozconfig
+
+# pentium4 specific options
+ac_add_options --disable-lto
-+export CC=gcc
-+export CXX=g++
-+export AR=gcc-ar
-+export NM=gcc-nm
-+export RANLIB=gcc-ranlib
++export CC=gcc-10
++export CXX=g++-10
++export AR=gcc-ar-10
++export NM=gcc-nm-10
++export RANLIB=gcc-ranlib-10
diff --git a/extra/firefox/mozconfig-pentium4.patch b/extra/firefox/mozconfig-pentium4.patch
index 03965a7a..ff2b1602 100644
--- a/extra/firefox/mozconfig-pentium4.patch
+++ b/extra/firefox/mozconfig-pentium4.patch
@@ -17,8 +17,8 @@ diff -rauN a/mozconfig b/mozconfig
+
+# pentium4 specific options
+ac_add_options --disable-lto
-+export CC=gcc
-+export CXX=g++
-+export AR=gcc-ar
-+export NM=gcc-nm
-+export RANLIB=gcc-ranlib
++export CC=gcc-10
++export CXX=g++-10
++export AR=gcc-ar-10
++export NM=gcc-nm-10
++export RANLIB=gcc-ranlib-10