summaryrefslogtreecommitdiff
path: root/extra/firefox
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-04-30 15:37:00 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-04-30 15:37:00 +0200
commit1f44b9291d4658448d557f455f846afaba9cd31e (patch)
treefe438d13cb82a49de6654d82108298ef7cb524d3 /extra/firefox
parentb0a36d1c3be3bf3295943527c1b2e5fe1b210675 (diff)
downloadpackages-1f44b9291d4658448d557f455f846afaba9cd31e.tar.xz
extra/firefox: stripping libxul.so by hand
Diffstat (limited to 'extra/firefox')
-rw-r--r--extra/firefox/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 823834f5..6c6a7965 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -234,3 +234,14 @@ eval "$(
$ i patch -p1 -i "$srcdir/firefox-99.0.1-fdlibm-double.patch"
'
)"
+
+# disable stripping in mozconfig.<arch> (insists to use llvm-strip which runs
+# out of memory on libxul.so. Now 2.5 GB can be strupped to 166 MB, so we do
+# that with the normal 'strip' from binutils after 'mach install'
+eval "$(
+ declare -f package | \
+ sed '
+ /.*mach.*install/ a \
+ strip "$pkgdir/usr/lib/$pkgname/libxul.so"
+ '
+)"