summaryrefslogtreecommitdiff
path: root/extra/firefox
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2020-04-21 20:31:01 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2020-04-21 20:31:01 +0200
commit17393e10e28e6a972de83e3720cc34a45e266856 (patch)
tree235f37425e122165b385e990272391e45cb283fa /extra/firefox
parent703fa81104790c820994fe99beee001413059af6 (diff)
downloadpackages-17393e10e28e6a972de83e3720cc34a45e266856.tar.xz
extra/firefox: added -mmmx for i686 for libvpx and _mm_empty intrinsic
Diffstat (limited to 'extra/firefox')
-rw-r--r--extra/firefox/PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 6eaccdb4..31c7632d 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -174,3 +174,12 @@ eval "$(
/msg2 "Profiling instrumented browser..."/,/.\/mach build/d
'
)"
+
+# libvpx has some hard-coded compiler flags for MMX, SSE, SSE2, use the correct one
+# per CARCH (75.0 uses an intrisic _mm_empty now, which required the corresponding
+# architecture flag to be preset - before it was merely embedding some assembly
+# code with EMMS
+if [ "${CARCH}" = "i686" ]; then
+ CFLAGS="$CFLAGS -mmmx"
+ CXXFLAGS="$CXXFLAGS -mmmx"
+fi