summaryrefslogtreecommitdiff
path: root/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-09-21 15:26:29 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-09-21 15:26:29 +0200
commitd33053e835cb907847878e34b5110aab240bc08b (patch)
tree55138ae7c1abb9c104c79af2953c487c0f4b1f0e /extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
parentc13ad2f7c758bf897c3c851bd9bd26e076a13743 (diff)
downloadpackages-d33053e835cb907847878e34b5110aab240bc08b.tar.xz
extra/firefox: patch doesn't work, so let's comment out the whole makefile section around the rust test
Diffstat (limited to 'extra/firefox/rust-static-disable-network-test-on-static-libraries.patch')
-rw-r--r--extra/firefox/rust-static-disable-network-test-on-static-libraries.patch29
1 files changed, 17 insertions, 12 deletions
diff --git a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
index 84dcc1d3..9e4baffa 100644
--- a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
+++ b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
@@ -1,19 +1,24 @@
diff -rauN a/config/makefiles/rust.mk b/config/makefiles/rust.mk
---- a/config/makefiles/rust.mk 2019-09-21 12:17:00.399732877 +0200
-+++ b/config/makefiles/rust.mk 2019-09-21 12:18:04.531378287 +0200
-@@ -244,6 +244,7 @@
+--- a/config/makefiles/rust.mk 2019-09-17 19:02:50.000000000 +0200
++++ b/config/makefiles/rust.mk 2019-09-21 15:24:51.554451253 +0200
+@@ -244,13 +244,13 @@
# When we are building in --enable-release mode; we add an additional check to confirm
# that we are not importing any networking-related functions in rust code. This reduces
# the chance of proxy bypasses originating from rust code.
-+ifndef MOZ_PROFILE_GENERATE
- ifndef DEVELOPER_OPTIONS
- ifndef MOZ_DEBUG_RUST
- ifeq ($(OS_ARCH), Linux)
-@@ -251,6 +252,7 @@
- endif
- endif
- endif
-+endif
+-ifndef DEVELOPER_OPTIONS
+-ifndef MOZ_DEBUG_RUST
+-ifeq ($(OS_ARCH), Linux)
+- $(call py_action,check_binary,--target --networking $@)
+-endif
+-endif
+-endif
++#ifndef DEVELOPER_OPTIONS
++#ifndef MOZ_DEBUG_RUST
++#ifeq ($(OS_ARCH), Linux)
++# $(call py_action,check_binary,--target --networking $@)
++#endif
++#endif
++#endif
force-cargo-library-check:
$(call CARGO_CHECK) --lib $(cargo_target_flag) $(rust_features_flag)