summaryrefslogtreecommitdiff
path: root/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-09-21 14:22:24 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-09-21 14:22:24 +0200
commit92f59742b9850db7f9be4c1c5fe18946cc045413 (patch)
tree5aa26c65e5d3bbbe1862982bd69095100ff3b6fa /extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
parent3c0b71074edc1d7a30d78fb48cdfcae6192abca7 (diff)
downloadpackages-92f59742b9850db7f9be4c1c5fe18946cc045413.tar.xz
extra/firefox: do not execute breaking rust tests
Diffstat (limited to 'extra/firefox/rust-static-disable-network-test-on-static-libraries.patch')
-rw-r--r--extra/firefox/rust-static-disable-network-test-on-static-libraries.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
new file mode 100644
index 00000000..84dcc1d3
--- /dev/null
+++ b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
@@ -0,0 +1,19 @@
+diff -rauN a/config/makefiles/rust.mk b/config/makefiles/rust.mk
+--- a/config/makefiles/rust.mk 2019-09-21 12:17:00.399732877 +0200
++++ b/config/makefiles/rust.mk 2019-09-21 12:18:04.531378287 +0200
+@@ -244,6 +244,7 @@
+ # When we are building in --enable-release mode; we add an additional check to confirm
+ # that we are not importing any networking-related functions in rust code. This reduces
+ # the chance of proxy bypasses originating from rust code.
++ifndef MOZ_PROFILE_GENERATE
+ ifndef DEVELOPER_OPTIONS
+ ifndef MOZ_DEBUG_RUST
+ ifeq ($(OS_ARCH), Linux)
+@@ -251,6 +252,7 @@
+ endif
+ endif
+ endif
++endif
+
+ force-cargo-library-check:
+ $(call CARGO_CHECK) --lib $(cargo_target_flag) $(rust_features_flag)