summaryrefslogtreecommitdiff
path: root/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2020-10-13 21:02:21 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2020-10-13 21:02:21 +0200
commit382feed3c76a23c9c3dc504083f648f93e50212a (patch)
treef48dea5d63ab7d8d069e969c0294c67cd9f037cc /extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
parent2c1c973d1dd56039132b1592349c5382cab2f417 (diff)
downloadpackages-382feed3c76a23c9c3dc504083f648f93e50212a.tar.xz
extra/firefox: redone patches for 81
Diffstat (limited to 'extra/firefox/rust-static-disable-network-test-on-static-libraries.patch')
-rw-r--r--extra/firefox/rust-static-disable-network-test-on-static-libraries.patch31
1 files changed, 15 insertions, 16 deletions
diff --git a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
index 95c2df7e..ba9e98c3 100644
--- a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
+++ b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
@@ -1,8 +1,7 @@
-diff --git a/config/makefiles/rust.mk b/config/makefiles/rust.mk
-index 58606db50f..9c4d5b9279 100644
---- a/config/makefiles/rust.mk
-+++ b/config/makefiles/rust.mk
-@@ -305,17 +305,17 @@ $(RUST_LIBRARY_FILE): force-cargo-library-build
+diff -rauN a/config/makefiles/rust.mk b/config/makefiles/rust.mk
+--- a/config/makefiles/rust.mk 2020-10-13 20:23:09.920635480 +0200
++++ b/config/makefiles/rust.mk 2020-10-13 20:24:02.273994137 +0200
+@@ -310,17 +310,17 @@
# the chance of proxy bypasses originating from rust code.
# The check only works when rust code is built with -Clto but without MOZ_LTO_RUST.
# Sanitizers and sancov also fail because compiler-rt hooks network functions.
@@ -17,17 +16,17 @@ index 58606db50f..9c4d5b9279 100644
-endif
-endif
-endif
-+# ifndef MOZ_PROFILE_GENERATE
-+# ifeq ($(OS_ARCH), Linux)
-+# ifeq (,$(rustflags_sancov)$(MOZ_ASAN)$(MOZ_TSAN)$(MOZ_UBSAN))
-+# ifndef MOZ_LTO_RUST
-+# ifneq (,$(filter -Clto,$(cargo_rustc_flags)))
-+# $(call py_action,check_binary,--target --networking $@)
-+# endif
-+# endif
-+# endif
-+# endif
-+# endif
++#ifndef MOZ_PROFILE_GENERATE
++#ifeq ($(OS_ARCH), Linux)
++#ifeq (,$(rustflags_sancov)$(MOZ_ASAN)$(MOZ_TSAN)$(MOZ_UBSAN))
++#ifndef MOZ_LTO_RUST
++#ifneq (,$(filter -Clto,$(cargo_rustc_flags)))
++# $(call py_action,check_binary,--target --networking $@)
++#endif
++#endif
++#endif
++#endif
++#endif
force-cargo-library-check:
$(call CARGO_CHECK) --lib $(cargo_target_flag) $(rust_features_flag)