summaryrefslogtreecommitdiff
path: root/extra/firefox/avoid-libxul-OOM-python-check.patch
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2020-10-13 21:02:21 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2020-10-13 21:02:21 +0200
commit382feed3c76a23c9c3dc504083f648f93e50212a (patch)
treef48dea5d63ab7d8d069e969c0294c67cd9f037cc /extra/firefox/avoid-libxul-OOM-python-check.patch
parent2c1c973d1dd56039132b1592349c5382cab2f417 (diff)
downloadpackages-382feed3c76a23c9c3dc504083f648f93e50212a.tar.xz
extra/firefox: redone patches for 81
Diffstat (limited to 'extra/firefox/avoid-libxul-OOM-python-check.patch')
-rw-r--r--extra/firefox/avoid-libxul-OOM-python-check.patch22
1 files changed, 11 insertions, 11 deletions
diff --git a/extra/firefox/avoid-libxul-OOM-python-check.patch b/extra/firefox/avoid-libxul-OOM-python-check.patch
index 04ce4958..63228113 100644
--- a/extra/firefox/avoid-libxul-OOM-python-check.patch
+++ b/extra/firefox/avoid-libxul-OOM-python-check.patch
@@ -1,30 +1,30 @@
-diff -rauN firefox-79.0/config/rules.mk firefox-79.0-avoid-libxul-OOM-python-check-patch/config/rules.mk
---- firefox-79.0/config/rules.mk 2020-07-21 00:49:36.000000000 +0200
-+++ firefox-79.0-avoid-libxul-OOM-python-check-patch/config/rules.mk 2020-08-02 14:04:30.846204786 +0200
+diff -rauN a/config/rules.mk b/config/rules.mk
+--- a/config/rules.mk 2020-10-13 20:28:50.994026769 +0200
++++ b/config/rules.mk 2020-10-13 20:29:06.594023940 +0200
@@ -470,7 +470,7 @@
- endif # MSVC with manifest tool
+ $(LINKER) -OUT:$@ -PDB:$(LINK_PDBFILE) -IMPLIB:$(basename $(@F)).lib $(WIN32_EXE_LDFLAGS) $(LDFLAGS) $(MOZ_PROGRAM_LDFLAGS) $($(notdir $@)_OBJS) $(filter %.res,$^) $(STATIC_LIBS) $(SHARED_LIBS) $(OS_LIBS)
else # !WINNT || GNU_CC
- $(call EXPAND_CC_OR_CXX,$@) -o $@ $(COMPUTED_CXX_LDFLAGS) $(PGO_CFLAGS) $($(notdir $@)_OBJS) $(RESFILE) $(WIN32_EXE_LDFLAGS) $(LDFLAGS) $(STATIC_LIBS) $(MOZ_PROGRAM_LDFLAGS) $(SHARED_LIBS) $(OS_LIBS)
+ $(call EXPAND_CC_OR_CXX,$@) -o $@ $(COMPUTED_CXX_LDFLAGS) $(PGO_CFLAGS) $($(notdir $@)_OBJS) $(filter %.res,$^) $(WIN32_EXE_LDFLAGS) $(LDFLAGS) $(STATIC_LIBS) $(MOZ_PROGRAM_LDFLAGS) $(SHARED_LIBS) $(OS_LIBS)
- $(call py_action,check_binary,--target $@)
+# $(call py_action,check_binary,--target $@)
endif # WINNT && !GNU_CC
ifdef ENABLE_STRIP
-@@ -526,7 +526,7 @@
- endif # MSVC with manifest tool
+@@ -514,7 +514,7 @@
+ $(LINKER) -out:$@ -pdb:$(LINK_PDBFILE) $($@_OBJS) $(filter %.res,$^) $(WIN32_EXE_LDFLAGS) $(LDFLAGS) $(MOZ_PROGRAM_LDFLAGS) $(STATIC_LIBS) $(SHARED_LIBS) $(OS_LIBS)
else
- $(call EXPAND_CC_OR_CXX,$@) $(COMPUTED_CXX_LDFLAGS) $(PGO_CFLAGS) -o $@ $($@_OBJS) $(WIN32_EXE_LDFLAGS) $(LDFLAGS) $(STATIC_LIBS) $(MOZ_PROGRAM_LDFLAGS) $(SHARED_LIBS) $(OS_LIBS)
+ $(call EXPAND_CC_OR_CXX,$@) $(COMPUTED_CXX_LDFLAGS) $(PGO_CFLAGS) -o $@ $($@_OBJS) $(filter %.res,$^) $(WIN32_EXE_LDFLAGS) $(LDFLAGS) $(STATIC_LIBS) $(MOZ_PROGRAM_LDFLAGS) $(SHARED_LIBS) $(OS_LIBS)
- $(call py_action,check_binary,--target $@)
+# $(call py_action,check_binary,--target $@)
endif # WINNT && !GNU_CC
ifdef ENABLE_STRIP
-@@ -606,7 +606,7 @@
+@@ -594,7 +594,7 @@
$(RM) $@
endif
- $(MKSHLIB) $($@_OBJS) $(RESFILE) $(LDFLAGS) $(STATIC_LIBS) $(SHARED_LIBS) $(EXTRA_DSO_LDOPTS) $(MOZ_GLUE_LDFLAGS) $(OS_LIBS)
+ $(MKSHLIB) $($@_OBJS) $(filter %.res,$^) $(LDFLAGS) $(STATIC_LIBS) $(SHARED_LIBS) $(EXTRA_DSO_LDOPTS) $(MOZ_GLUE_LDFLAGS) $(OS_LIBS)
- $(call py_action,check_binary,--target $@)
+# $(call py_action,check_binary,--target $@)
ifeq (_WINNT,$(GNU_CC)_$(OS_ARCH))
- ifdef MSMANIFEST_TOOL
+ endif # WINNT && !GCC