summaryrefslogtreecommitdiff
path: root/extra/firefox/avoid-libxul-OOM-python-check.patch
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2020-08-02 15:13:23 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2020-08-02 15:13:23 +0200
commit28a23a9e45213bfa33fa9a01309e6cc489bbbaa4 (patch)
treede4aa3f6eb9e859bdcf7d9e5f80c30b7d3f7ae9e /extra/firefox/avoid-libxul-OOM-python-check.patch
parentf5a99c945558e5d95ba722228b4f061b9e9afd91 (diff)
downloadpackages-28a23a9e45213bfa33fa9a01309e6cc489bbbaa4.tar.xz
extra/firefox: repatched for 79.0
Diffstat (limited to 'extra/firefox/avoid-libxul-OOM-python-check.patch')
-rw-r--r--extra/firefox/avoid-libxul-OOM-python-check.patch23
1 files changed, 12 insertions, 11 deletions
diff --git a/extra/firefox/avoid-libxul-OOM-python-check.patch b/extra/firefox/avoid-libxul-OOM-python-check.patch
index 4aaf550c..04ce4958 100644
--- a/extra/firefox/avoid-libxul-OOM-python-check.patch
+++ b/extra/firefox/avoid-libxul-OOM-python-check.patch
@@ -1,29 +1,30 @@
---- firefox-77.0.1/config/rules.mk 2020-06-03 03:04:50.000000000 +0200
-+++ firefox-77.0.1-avoid-libxul-OOM-python-check-patch/config/rules.mk 2020-06-04 16:43:06.709092454 +0200
-@@ -474,7 +474,7 @@
+diff -rauN firefox-79.0/config/rules.mk firefox-79.0-avoid-libxul-OOM-python-check-patch/config/rules.mk
+--- firefox-79.0/config/rules.mk 2020-07-21 00:49:36.000000000 +0200
++++ firefox-79.0-avoid-libxul-OOM-python-check-patch/config/rules.mk 2020-08-02 14:04:30.846204786 +0200
+@@ -470,7 +470,7 @@
endif # MSVC with manifest tool
else # !WINNT || GNU_CC
$(call EXPAND_CC_OR_CXX,$@) -o $@ $(COMPUTED_CXX_LDFLAGS) $(PGO_CFLAGS) $($(notdir $@)_OBJS) $(RESFILE) $(WIN32_EXE_LDFLAGS) $(LDFLAGS) $(STATIC_LIBS) $(MOZ_PROGRAM_LDFLAGS) $(SHARED_LIBS) $(OS_LIBS)
-- $(call py3_action,check_binary,--target $@)
-+# $(call py3_action,check_binary,--target $@)
+- $(call py_action,check_binary,--target $@)
++# $(call py_action,check_binary,--target $@)
endif # WINNT && !GNU_CC
ifdef ENABLE_STRIP
-@@ -530,7 +530,7 @@
+@@ -526,7 +526,7 @@
endif # MSVC with manifest tool
else
$(call EXPAND_CC_OR_CXX,$@) $(COMPUTED_CXX_LDFLAGS) $(PGO_CFLAGS) -o $@ $($@_OBJS) $(WIN32_EXE_LDFLAGS) $(LDFLAGS) $(STATIC_LIBS) $(MOZ_PROGRAM_LDFLAGS) $(SHARED_LIBS) $(OS_LIBS)
-- $(call py3_action,check_binary,--target $@)
-+# $(call py3_action,check_binary,--target $@)
+- $(call py_action,check_binary,--target $@)
++# $(call py_action,check_binary,--target $@)
endif # WINNT && !GNU_CC
ifdef ENABLE_STRIP
-@@ -610,7 +610,7 @@
+@@ -606,7 +606,7 @@
$(RM) $@
endif
$(MKSHLIB) $($@_OBJS) $(RESFILE) $(LDFLAGS) $(STATIC_LIBS) $(SHARED_LIBS) $(EXTRA_DSO_LDOPTS) $(MOZ_GLUE_LDFLAGS) $(OS_LIBS)
-- $(call py3_action,check_binary,--target $@)
-+# $(call py3_action,check_binary,--target $@)
+- $(call py_action,check_binary,--target $@)
++# $(call py_action,check_binary,--target $@)
ifeq (_WINNT,$(GNU_CC)_$(OS_ARCH))
ifdef MSMANIFEST_TOOL