summaryrefslogtreecommitdiff
path: root/extra/firefox/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2020-04-04 17:04:20 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2020-04-04 17:04:20 +0200
commit8f2722474333379dcd8c875f23d274fe2fb25c61 (patch)
treeb58aae2a80a280feec93050c7906c7c5cd676570 /extra/firefox/PKGBUILD
parent11463df0cc4a38a0ca189b1cfaadcd2f08d44dda (diff)
downloadpackages-8f2722474333379dcd8c875f23d274fe2fb25c61.tar.xz
extra/firefox: split mozconfig for i686/pentium4, fixed non-SIMD build on i686
Diffstat (limited to 'extra/firefox/PKGBUILD')
-rw-r--r--extra/firefox/PKGBUILD26
1 files changed, 22 insertions, 4 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 2fb535bf..6eaccdb4 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -1,8 +1,27 @@
# disable LTO as it has little benefit and uses too many resources
# don't compile with clang, use gcc toolchain (clang has issues on IA32)
-# TODO: document the rest..
-source+=('mozconfig.patch')
-sha256sums+=('708605f390994587277d8357e8452a71fcbfab97394df9678b1b646539e4ce20')
+# disable SIMD (SSE20 for i686
+# set correct compiler and toochain tools
+if [ "${CARCH}" = "pentium4" ]; then
+ source+=('mozconfig-pentium4.patch')
+ sha256sums+=('708605f390994587277d8357e8452a71fcbfab97394df9678b1b646539e4ce20')
+eval "$(
+ declare -f prepare | \
+ sed '
+ $ i patch -d .. -Np1 -i "$srcdir/mozconfig-pentium4.patch"
+ '
+)"
+fi
+if [ "${CARCH}" = "i686" ]; then
+ source+=('mozconfig-i686.patch')
+ sha256sums+=('b6688e8872da4651653d898ba832d078e30e901bc6b84df07494905320633f22')
+eval "$(
+ declare -f prepare | \
+ sed '
+ $ i patch -d .. -Np1 -i "$srcdir/mozconfig-i686.patch"
+ '
+)"
+fi
eval "$(
declare -f build | \
sed '
@@ -12,7 +31,6 @@ eval "$(
declare -f prepare | \
sed '
$ i export MOZ_SOURCE_CHANGESET="DEVEDITION_${pkgver//./_}_RELEASE"
- $ i patch -d .. -Np1 -i "$srcdir/mozconfig.patch"
'
)"