summaryrefslogtreecommitdiff
path: root/extra/firefox/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-10-25 11:20:37 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-10-25 11:20:37 +0200
commit5b58d7c64badaec49e8d965b0c848afa27ac90f2 (patch)
treed9d1b31823647d69d47e706a65124f6c3c6d7a3c /extra/firefox/PKGBUILD
parent17e743a5025142e4fe39b9c8d8ad27baf70af971 (diff)
downloadpackages-5b58d7c64badaec49e8d965b0c848afa27ac90f2.tar.xz
extra/firefox: redone all patches
Diffstat (limited to 'extra/firefox/PKGBUILD')
-rw-r--r--extra/firefox/PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 34212cde..6a2bd9ff 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -2,7 +2,7 @@
# don't compile with clang, use gcc toolchain (clang has issues on IA32)
# TODO: document the rest..
source+=('mozconfig.patch')
-sha256sums+=('62eb5b45f7eaa1879f9c9b0df92ed8de869a25b05ef6cd71c699cb44cee7cc97')
+sha256sums+=('0dcc5435b83e39f5725850818494617f2098d7535619ee169237d450489d6260')
eval "$(
declare -f build | \
sed '
@@ -12,7 +12,7 @@ eval "$(
declare -f prepare | \
sed '
$ i export MOZ_SOURCE_CHANGESET="DEVEDITION_${pkgver//./_}_RELEASE"
- $ i patch -p1 -i "$srcdir/mozconfig.patch"
+ $ i patch -d .. -Np1 -i "$srcdir/mozconfig.patch"
'
)"
@@ -96,7 +96,7 @@ eval "$(
# test failure in rust code (complaining about network functions) when PGO is used,
# see https://bugzilla.mozilla.org/show_bug.cgi?id=1565757
source+=('rust-static-disable-network-test-on-static-libraries.patch')
-sha256sums+=('34eea882ba21a0ce641f352a200ede115a8d4befd16fe43303ba1d0aa7f90abd')
+sha256sums+=('d07e283d5c784bb44dcd0ad3f6b82f19cac562451ce07033e8dde50bf8c75d76')
eval "$(
declare -f prepare | \
sed '
@@ -106,7 +106,7 @@ eval "$(
# readelf: Error: Unable to seek to 0x801db328 for section headers
source+=('avoid-libxul-OOM-python-check.patch')
-sha256sums+=('00b7019218d015a11670d566bff6d62872357c29ee7f9ef4d29a7f63c46227b6')
+sha256sums+=('5a3e038a57c4576dcb88766d41cbfda5ad109d5cfe41d2000f7ba25563bf00f2')
eval "$(
declare -f prepare | \
sed '