summaryrefslogtreecommitdiff
path: root/extra/firefox/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2020-10-13 21:02:21 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2020-10-13 21:02:21 +0200
commit382feed3c76a23c9c3dc504083f648f93e50212a (patch)
treef48dea5d63ab7d8d069e969c0294c67cd9f037cc /extra/firefox/PKGBUILD
parent2c1c973d1dd56039132b1592349c5382cab2f417 (diff)
downloadpackages-382feed3c76a23c9c3dc504083f648f93e50212a.tar.xz
extra/firefox: redone patches for 81
Diffstat (limited to 'extra/firefox/PKGBUILD')
-rw-r--r--extra/firefox/PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 6adaa234..fe7b629c 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -1,6 +1,6 @@
# disable LTO as it has little benefit and uses too many resources
# don't compile with clang, use gcc toolchain (clang has issues on IA32)
-# disable SIMD (SSE20 for i686
+# disable SIMD (SSE2 for i686)
# set correct compiler and toochain tools
if [ "${CARCH}" = "pentium4" ]; then
source+=('mozconfig-pentium4.patch')
@@ -22,6 +22,8 @@ eval "$(
'
)"
fi
+
+# try hard to tell ld and rust not to use too much memory (no lto, no debug info, etc.)
eval "$(
declare -f build | \
sed '
@@ -125,7 +127,7 @@ eval "$(
# test failure in rust code (complaining about network functions) when PGO is used,
# see https://bugzilla.mozilla.org/show_bug.cgi?id=1565757
source+=('rust-static-disable-network-test-on-static-libraries.patch')
-sha256sums+=('e661665ee00ecec66c33e115b0af3474452022f0d8ceda634a6315dc8cb99014')
+sha256sums+=('bd55e25fbaf36bb9d01198024930e3a1a275533ffd6c142b3be70bfbc33b4577')
eval "$(
declare -f prepare | \
sed '
@@ -145,7 +147,7 @@ eval "$(
# readelf: Error: Unable to seek to 0x801db328 for section headers
source+=('avoid-libxul-OOM-python-check.patch')
-sha256sums+=('bf2829f280ef05a608584ce7ec95875e147f315bac9609f5e18052bc03e3c4f9')
+sha256sums+=('2f0c81a38c4578f68f5456b618fe84a78974072821488173eb55e0e72287e353')
eval "$(
declare -f prepare | \
sed '