summaryrefslogtreecommitdiff
path: root/extra/firefox/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2020-04-04 14:22:50 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2020-04-04 14:22:50 +0200
commit11463df0cc4a38a0ca189b1cfaadcd2f08d44dda (patch)
tree34bb19e23716127e404d674bb848c1a88a2599ed /extra/firefox/PKGBUILD
parent3dcb46e2e5510696c5cc3bb26c688061dfbc27be (diff)
downloadpackages-11463df0cc4a38a0ca189b1cfaadcd2f08d44dda.tar.xz
extra/firefox: a first trial to fix building
Diffstat (limited to 'extra/firefox/PKGBUILD')
-rw-r--r--extra/firefox/PKGBUILD17
1 files changed, 14 insertions, 3 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 11d9d040..2fb535bf 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -2,7 +2,7 @@
# don't compile with clang, use gcc toolchain (clang has issues on IA32)
# TODO: document the rest..
source+=('mozconfig.patch')
-sha256sums+=('f0de0124f841ce219a6816383cf500b4cc157e34df71d4d9fe7bd7e23047440c')
+sha256sums+=('708605f390994587277d8357e8452a71fcbfab97394df9678b1b646539e4ce20')
eval "$(
declare -f build | \
sed '
@@ -16,6 +16,17 @@ eval "$(
'
)"
+# do not build a first firefox, run it in headless X just to produce
+# some profiling data and build it again. the penalty of using a 32-bit
+# build is high enough, so optimizing based on profiling data will not
+# be that helpfull IMHO.
+eval "$(
+ declare -f build | \
+ sed '
+ /.\/mach package/,/.\/mach build/d
+ '
+)"
+
# use locally cached version of firefox sources
# TODO: think about how to put this into helper functions
for ((i=0; i<${#source[@]}; i++)); do
@@ -96,7 +107,7 @@ eval "$(
# test failure in rust code (complaining about network functions) when PGO is used,
# see https://bugzilla.mozilla.org/show_bug.cgi?id=1565757
source+=('rust-static-disable-network-test-on-static-libraries.patch')
-sha256sums+=('4da71f6614dce71db8e9ec2d317514aae90838c2c65620d435f0df06b45b578b')
+sha256sums+=('7ef04324ca732df50fc33f21d8e7027c43e3c7c3a51d2332dd44853910315a67')
eval "$(
declare -f prepare | \
sed '
@@ -116,7 +127,7 @@ eval "$(
# readelf: Error: Unable to seek to 0x801db328 for section headers
source+=('avoid-libxul-OOM-python-check.patch')
-sha256sums+=('5a3e038a57c4576dcb88766d41cbfda5ad109d5cfe41d2000f7ba25563bf00f2')
+sha256sums+=('6395b7e349963c9a689929b44525159328954af156ef0b9a42182e7e16baa8ba')
eval "$(
declare -f prepare | \
sed '