summaryrefslogtreecommitdiff
path: root/extra/ffmpeg
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-01-16 15:03:18 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2021-01-16 15:03:18 +0100
commit785e11ce29c34a9924bd7c152557de366480d055 (patch)
tree1d6a290e5564eb98566743d6fae4af299e8885ca /extra/ffmpeg
parenta189b54dda8dd8fd9a127540a3a1e8fc10671c57 (diff)
downloadpackages-785e11ce29c34a9924bd7c152557de366480d055.tar.xz
extra/gegl: no vala API on i486
Diffstat (limited to 'extra/ffmpeg')
-rw-r--r--extra/ffmpeg/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/extra/ffmpeg/PKGBUILD b/extra/ffmpeg/PKGBUILD
index f0f6f8e1..7c2a7aed 100644
--- a/extra/ffmpeg/PKGBUILD
+++ b/extra/ffmpeg/PKGBUILD
@@ -20,3 +20,32 @@ fi
# force picking of a modern libvpx and not libvpx1.3 needed for steam
makedepends+=('libvpx>=1.8.2')
+
+# no AviSynthPlus on i486 (uses Intel intrinsics and cmake support for
+# disabling it is broken)
+makedepends=(${makedepends[@]//avisynthplus/})
+makedepends_i686+=(avisynthplus)
+makedepends_pentium4=("${makedepends_i686[@]}")
+if [ "$CARCH" == 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/-enable-avisynth/--disable-avisynth/
+ '
+ )"
+fi
+
+# still required dependencies on i486:
+# sdl2
+# - ibus
+# - gtk3
+# - libnotify
+# - python-gobject
+# - gtk2
+# - qt5-base
+# - unicode-cldr
+# - fcitx
+# v4l-utils
+# - qt5-base
+# - mariadb-libs
+# - qtk3