summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-07-29 17:54:52 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-07-29 17:54:52 +0200
commite032e047269011dac100add0e6ae0fa4c1883444 (patch)
tree89390a2de5a8d96ce6373942cdd49d2397269336 /core
parent5b6f9444dac290024456a6b0d2fb5e930a7e397f (diff)
downloadpackages-e032e047269011dac100add0e6ae0fa4c1883444.tar.xz
core/elfutils: backported fix for backtrace test (printf null format error)
Diffstat (limited to 'core')
-rw-r--r--core/elfutils/PKGBUILD9
-rw-r--r--core/elfutils/elfutils-backtrace-test-printf-fix.patch11
2 files changed, 20 insertions, 0 deletions
diff --git a/core/elfutils/PKGBUILD b/core/elfutils/PKGBUILD
index 946c7001..7f7584db 100644
--- a/core/elfutils/PKGBUILD
+++ b/core/elfutils/PKGBUILD
@@ -8,3 +8,12 @@ eval "$(
}
'
)"
+
+# backport from git://sourceware.org/git/elfutils.git
+source+=(elfutils-backtrace-test-printf-fix.patch)
+sha1sums+=('c14beffa1fcd1116ae9c388ebba16cf3f668da92')
+
+prepare() {
+ cd ${pkgbase}-${pkgver}
+ patch -Np1 -i "$srcdir/elfutils-backtrace-test-printf-fix.patch"
+}
diff --git a/core/elfutils/elfutils-backtrace-test-printf-fix.patch b/core/elfutils/elfutils-backtrace-test-printf-fix.patch
new file mode 100644
index 00000000..f8fa3784
--- /dev/null
+++ b/core/elfutils/elfutils-backtrace-test-printf-fix.patch
@@ -0,0 +1,11 @@
+--- elfutils-0.176/tests/backtrace.c 2019-02-15 16:46:47.000000000 +0100
++++ elfutils-git/tests/backtrace.c 2019-07-29 17:43:34.963057739 +0200
+@@ -185,7 +185,7 @@
+ symname = dwfl_module_addrname (mod, pc_adjusted);
+
+ printf ("#%2d %#" PRIx64 "%4s\t%s\n", *framenop, (uint64_t) pc,
+- ! isactivation ? "- 1" : "", symname);
++ ! isactivation ? "- 1" : "", symname ?: "<null>");
+ pid_t tid = dwfl_thread_tid (thread);
+ callback_verify (tid, *framenop, pc, symname, dwfl);
+ (*framenop)++;