summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2018-09-13 16:02:07 +0200
committerErich Eckner <git@eckner.net>2018-09-13 16:02:07 +0200
commitd387b6c2efb66e95632beb897d56abcbd2a8d9fb (patch)
tree11dab0f833a1a0cde01cccf90530b21bf3a07c91 /core
parent13160576b99ff949630f0e0ed7493725a6a9156f (diff)
downloadpackages-d387b6c2efb66e95632beb897d56abcbd2a8d9fb.tar.xz
core/binutils: incorporate i486 changes
Diffstat (limited to 'core')
-rw-r--r--core/binutils/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/core/binutils/PKGBUILD b/core/binutils/PKGBUILD
index a3f00f0f..711a8ed0 100644
--- a/core/binutils/PKGBUILD
+++ b/core/binutils/PKGBUILD
@@ -25,3 +25,14 @@ eval "$(
/0004-PR22868/a patch -p1 -i ${srcdir}/binutils-2.30-glibc-segfault.patch
'
)"
+
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # disable CET (Control Flow instructions endbr32/enbr64)
+ eval "$(
+ declare -f build | \
+ sed '
+ s,configure",configure" --disable-cet,
+ '
+ )"
+fi