summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-09-20 10:32:47 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-09-20 10:32:47 +0200
commitd12ccfc9e9d74544c05ea08f79c2b5de6839d7ae (patch)
tree32d9bcfe12edc79e7cba5bd796b671c89eec498e /core
parent0a1b1b63394aaa4e687770b88dc56a5d3069158a (diff)
downloadpackages-d12ccfc9e9d74544c05ea08f79c2b5de6839d7ae.tar.xz
core/elfutils: removed printf patch (is fixed upstream)
Diffstat (limited to 'core')
-rw-r--r--core/elfutils/PKGBUILD19
-rw-r--r--core/elfutils/elfutils-backtrace-test-printf-fix.patch11
2 files changed, 0 insertions, 30 deletions
diff --git a/core/elfutils/PKGBUILD b/core/elfutils/PKGBUILD
deleted file mode 100644
index 7f7584db..00000000
--- a/core/elfutils/PKGBUILD
+++ /dev/null
@@ -1,19 +0,0 @@
-eval "$(
- declare -f build | \
- sed '
- /^\s*CFLAGS+=/{
- a\
- export CFLAGS=${CFLAGS/-fno-plt}\
- export CXXFLAGS=${CXXFLAGS/-fno-plt}
- }
- '
-)"
-
-# backport from git://sourceware.org/git/elfutils.git
-source+=(elfutils-backtrace-test-printf-fix.patch)
-sha1sums+=('c14beffa1fcd1116ae9c388ebba16cf3f668da92')
-
-prepare() {
- cd ${pkgbase}-${pkgver}
- patch -Np1 -i "$srcdir/elfutils-backtrace-test-printf-fix.patch"
-}
diff --git a/core/elfutils/elfutils-backtrace-test-printf-fix.patch b/core/elfutils/elfutils-backtrace-test-printf-fix.patch
deleted file mode 100644
index f8fa3784..00000000
--- a/core/elfutils/elfutils-backtrace-test-printf-fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- elfutils-0.176/tests/backtrace.c 2019-02-15 16:46:47.000000000 +0100
-+++ elfutils-git/tests/backtrace.c 2019-07-29 17:43:34.963057739 +0200
-@@ -185,7 +185,7 @@
- symname = dwfl_module_addrname (mod, pc_adjusted);
-
- printf ("#%2d %#" PRIx64 "%4s\t%s\n", *framenop, (uint64_t) pc,
-- ! isactivation ? "- 1" : "", symname);
-+ ! isactivation ? "- 1" : "", symname ?: "<null>");
- pid_t tid = dwfl_thread_tid (thread);
- callback_verify (tid, *framenop, pc, symname, dwfl);
- (*framenop)++;