summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-07-19 06:48:18 +0000
committerAndreas Baumann <mail@andreasbaumann.cc>2018-07-19 06:48:18 +0000
commitb64e0b3dbff5e76b791843eb2f82c6e9efe963d8 (patch)
tree7353a63d7e15398f43232fb96cc7cc26b609ff36 /core
parentd516581ef278b49536a43d8de664d50197280ead (diff)
downloadpackages-b64e0b3dbff5e76b791843eb2f82c6e9efe963d8.tar.xz
core/make: added patch for FS#58674
Diffstat (limited to 'core')
-rw-r--r--core/make/FS58674.patch15
-rw-r--r--core/make/PKGBUILD6
2 files changed, 19 insertions, 2 deletions
diff --git a/core/make/FS58674.patch b/core/make/FS58674.patch
new file mode 100644
index 00000000..82f42ea5
--- /dev/null
+++ b/core/make/FS58674.patch
@@ -0,0 +1,15 @@
+diff -rauN make-4.2.1/configure.ac make-4.2.1-alloca-patch/configure.ac
+--- make-4.2.1/configure.ac 2016-06-06 12:27:31.000000000 +0000
++++ make-4.2.1-alloca-patch/configure.ac 2018-07-19 06:17:41.011662796 +0000
+@@ -399,10 +399,9 @@
+ #include <glob.h>
+ #include <fnmatch.h>
+
+-#define GLOB_INTERFACE_VERSION 1
+ #if !defined _LIBC && defined __GNU_LIBRARY__ && __GNU_LIBRARY__ > 1
+ # include <gnu-versions.h>
+-# if _GNU_GLOB_INTERFACE_VERSION == GLOB_INTERFACE_VERSION
++# if _GNU_GLOB_INTERFACE_VERSION == 1 || _GNU_GLOB_INTERFACE_VERSION == 2
+ gnu glob
+ # endif
+ #endif],
diff --git a/core/make/PKGBUILD b/core/make/PKGBUILD
index 4be2e8bb..0696a710 100644
--- a/core/make/PKGBUILD
+++ b/core/make/PKGBUILD
@@ -1,8 +1,10 @@
-source+=('FS55127.patch')
-md5sums+=('8efba0d7ff90f5394edda0f83259af05')
+source+=('FS55127.patch' 'FS58674.patch')
+md5sums+=('8efba0d7ff90f5394edda0f83259af05' '95fcc032a728e134f620a402e6922389')
+
eval "$(
declare -f prepare | \
sed '
/^\s*cd\s/a patch -p1 -i ${srcdir}/FS55127.patch
+ /^\s*cd\s/a patch -p1 -i ${srcdir}/FS58674.patch
'
)"