summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-08-05 15:45:06 +0000
committerAndreas Baumann <mail@andreasbaumann.cc>2018-08-05 15:45:06 +0000
commit89614e8a42bb140dc1cbb5b5111d775b818de6a9 (patch)
treec62b1fda0a320286d9772c9082ec903742cdd1f1 /core
parentefb303ea98dd6c6ecb298612906d3f58617e758c (diff)
downloadpackages-89614e8a42bb140dc1cbb5b5111d775b818de6a9.tar.xz
core/gcc: added i486-specific patch
Diffstat (limited to 'core')
-rw-r--r--core/gcc/PKGBUILD65
1 files changed, 65 insertions, 0 deletions
diff --git a/core/gcc/PKGBUILD b/core/gcc/PKGBUILD
index 86d70aae..0fe8efff 100644
--- a/core/gcc/PKGBUILD
+++ b/core/gcc/PKGBUILD
@@ -46,3 +46,68 @@ eval "$(
'
done
)"
+
+# fix bug url
+eval "$(
+ declare -f build | \
+ sed '
+ s,--with-bugurl=https://bugs.archlinux.org/,--with-bugurl=https://bugs.archlinux32.org/,
+ '
+)"
+
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # disable doxygen documentation
+ makedepends=(${makedepends[@]//doxygen/})
+
+ eval "$(
+ declare -f build | \
+ sed '
+ /make.*doc-man-doxygen/d
+ '
+ )"
+
+ eval "$(
+ declare -f package_gcc | \
+ sed '
+ /make.*doc-man-doxygen/d
+ /make.*doc-install-man/d
+ '
+ )"
+
+ # no ADA
+ makedepends=(${makedepends[@]//gcc-ada/})
+
+ pkgname=(${pkgname[@]//gcc-ada/})
+
+ eval "$(
+ declare -f build | \
+ sed '
+ /enable-languages/ s/ada//
+ '
+ )"
+
+ eval "$(
+ declare -f package_gcc | \
+ sed '
+ s/,gnat-style,gnat_rm,gnat_ugn//
+ '
+ )"
+
+ # building toolchain (gcc): again, lobtool problems
+ # /usr/lib/gcc/i486-pc-linux-gnu/7.3.0/ld: cannot find -lquadmath
+ # collect2: error: ld returned 1 exit status
+ # libtool: install: error: relink `libgfortran.la' with the above command before installing it
+ # make: Leaving directory '/build/gcc/src/gcc-build/i486-pc-linux-gnu/libgfortran'
+ # => wrong link order: libgfortran requires libquadmath
+ eval "$(
+ declare -f package_gcc-libs | \
+ sed '
+ s/libgfortran/libquadmath libgfortran/
+ '
+ )"
+
+fi
+
+
+