summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-05-19 14:45:13 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-05-19 14:45:13 +0200
commit8856017326243162d03ae11b1c57c376673bb34e (patch)
tree51506424b248938d7e6c869570715b4dbb39465b /core
parentd8491a23384ccc5909242cd9893f3c7c3c8e69bc (diff)
downloadpackages-8856017326243162d03ae11b1c57c376673bb34e.tar.xz
core/python: also disabled test_compileall test
Diffstat (limited to 'core')
-rw-r--r--core/python/PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/core/python/PKGBUILD b/core/python/PKGBUILD
index 03027ece..aa4a7b5e 100644
--- a/core/python/PKGBUILD
+++ b/core/python/PKGBUILD
@@ -44,12 +44,13 @@ fi
# test_gdb currently fails for unknown reasons, also not that important
# test_socket tests take more than 1.5 hours, so ignoring them
# Ignore test_cmath test_math test_turtle - they fail due to too low precision
-# on i686 (all of them - really? - actually, I just checket test_cmath)
-# test_multiprocessing_forkserver, test_concurrent_futures hang at least on i486
+# on i686 (all of them - really? - actually, I just checket test_cmath),
+# test_multiprocessing_forkserver, test_concurrent_futures, test_compileall
+# all hang at least on i486
eval "$(
declare -f check | \
sed "
- /-uall/ s/;\?$/ -x test_posix -x test_gdb -x test_socket -x test_cmath -x test_math -x test_turtle -x test_multiprocessing_forkserver -x test_concurrent_futures \\|\\| true/g
+ /-uall/ s/;\?$/ -x test_posix -x test_gdb -x test_socket -x test_cmath -x test_math -x test_turtle -x test_multiprocessing_forkserver -x test_concurrent_futures -x test_compileall \\|\\| true/g
"
)"