summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-10-14 13:11:46 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2018-10-14 13:11:46 +0200
commit79ea66c11eb28078d7879822b7d783dad8c8eb7d (patch)
tree0f6b3047bd0fc0b7c57a39ce620d41961bf2e691 /core
parente55219eb7ae5a883883bc562043e09bec8885e5a (diff)
downloadpackages-79ea66c11eb28078d7879822b7d783dad8c8eb7d.tar.xz
core/libaio: fix for failing tests (see FS#60283)
Diffstat (limited to 'core')
-rw-r--r--core/libaio/PKGBUILD8
-rw-r--r--core/libaio/libaio-0.3.111-sizeof-template.patch24
2 files changed, 32 insertions, 0 deletions
diff --git a/core/libaio/PKGBUILD b/core/libaio/PKGBUILD
index 92c69c31..a4cbd68f 100644
--- a/core/libaio/PKGBUILD
+++ b/core/libaio/PKGBUILD
@@ -7,3 +7,11 @@ eval "$(
s@make$@CFLAGS="-march=${CARCH/_/-} -mtune=generic -O2 -pipe -fno-stack-protector" make@
'
)"
+
+# see also FS#60283
+source+=('libaio-0.3.111-sizeof-template.patch')
+md5sums+=('8c240ea721460fa2d34f9e134b57544d')
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i ../libaio-0.3.111-sizeof-template.patch
+}
diff --git a/core/libaio/libaio-0.3.111-sizeof-template.patch b/core/libaio/libaio-0.3.111-sizeof-template.patch
new file mode 100644
index 00000000..5eee8958
--- /dev/null
+++ b/core/libaio/libaio-0.3.111-sizeof-template.patch
@@ -0,0 +1,24 @@
+diff -rauN libaio-0.3.111/harness/cases/19.t libaio-0.3.111-sizeof-template-patch/harness/cases/19.t
+--- libaio-0.3.111/harness/cases/19.t 2018-03-06 23:24:47.000000000 +0100
++++ libaio-0.3.111-sizeof-template-patch/harness/cases/19.t 2018-10-14 10:02:19.004873314 +0200
+@@ -41,7 +41,7 @@
+ int fd;
+ char template[sizeof(TEMPLATE)];
+
+- strncpy(template, TEMPLATE, sizeof(TEMPLATE));
++ strncpy(template, TEMPLATE, sizeof(template));
+ fd = mkostemp(template, O_DIRECT);
+ if (fd < 0) {
+ perror("mkstemp");
+diff -rauN libaio-0.3.111/harness/cases/21.t libaio-0.3.111-sizeof-template-patch/harness/cases/21.t
+--- libaio-0.3.111/harness/cases/21.t 2018-03-06 23:24:47.000000000 +0100
++++ libaio-0.3.111-sizeof-template-patch/harness/cases/21.t 2018-10-14 10:02:34.901333421 +0200
+@@ -43,7 +43,7 @@
+ int fd;
+ char temp_file[sizeof(TEMPLATE)];
+
+- strncpy(temp_file, TEMPLATE, sizeof(TEMPLATE));
++ strncpy(temp_file, TEMPLATE, sizeof(temp_file));
+ fd = mkstemp(temp_file);
+ if (fd < 0) {
+ perror("mkstemp");