summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-21 10:09:43 +0100
committerErich Eckner <git@eckner.net>2019-01-21 10:09:43 +0100
commit70a7c30b8196a4398cf755b93507516d0f83be56 (patch)
tree209c100961292220e8af6a75f6eccf2cf9a0e440 /core
parent22d62828d91c69d6ec0db0ab42be321a0370f561 (diff)
parentbdaf29915201bec1e7ebffb37bf9f96a7dd529e8 (diff)
downloadpackages-70a7c30b8196a4398cf755b93507516d0f83be56.tar.xz
Merge branch 'master' into i486
Diffstat (limited to 'core')
-rw-r--r--core/linux/PKGBUILD8
-rw-r--r--core/linux/config.i4863
-rw-r--r--core/linux/config.i6863
-rw-r--r--core/systemd/PKGBUILD11
-rw-r--r--core/systemd/lz4-test-compress-partial.patch31
5 files changed, 6 insertions, 50 deletions
diff --git a/core/linux/PKGBUILD b/core/linux/PKGBUILD
index 4db8d6d5..6310e45b 100644
--- a/core/linux/PKGBUILD
+++ b/core/linux/PKGBUILD
@@ -1,12 +1,12 @@
-# upstream git revision: bcc459d290364f660363c1517aa502ce7bf76df7
+# upstream git revision: 45f74c7ee0c0d228f516a775817769db3192f978
source_i686=('config.i686')
source_i486=('config.i486')
# fail if upstream's .config changes
for ((i=0; i<${#sha256sums[@]}; i++)); do
- if [ "${sha256sums[${i}]}" = '588a2eb551397cd6b5cfc2434fb6936819779f43ff03f112289e17fa08390ca9' ]; then
- sha256sums_i686=('5ab5359e1382ac17ef094842c727d3e5d75e1f5e0dda1649ea2c238688653edd')
- sha256sums_i486=('22622966ba79b732c05d2bc3a8dec9f825a5c3ed3049882aed5f51efd9da9392')
+ if [ "${sha256sums[${i}]}" = '986918689166b88f03579bda4a5a964ec4a1db18423b89981ba58da7e35e8e89' ]; then
+ sha256sums_i686=('bd4295f9ccd4e19755c589e711791b7937de3f5685a29de2b30f6b193acc0bc9')
+ sha256sums_i486=('124ae6377726257edae0312eba64fe70758d321c7997e90e021ad3676441c1fe')
fi
done
diff --git a/core/linux/config.i486 b/core/linux/config.i486
index 25c6a014..ad6b63d2 100644
--- a/core/linux/config.i486
+++ b/core/linux/config.i486
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.19.1-arch1 Kernel Configuration
+# Linux/x86 4.19.2-arch1 Kernel Configuration
#
#
@@ -9274,7 +9274,6 @@ CONFIG_CRYPTO_SEED=m
CONFIG_CRYPTO_SERPENT=m
CONFIG_CRYPTO_SERPENT_SSE2_586=m
# CONFIG_CRYPTO_SM4 is not set
-# CONFIG_CRYPTO_SPECK is not set
CONFIG_CRYPTO_TEA=m
CONFIG_CRYPTO_TWOFISH=m
CONFIG_CRYPTO_TWOFISH_COMMON=m
diff --git a/core/linux/config.i686 b/core/linux/config.i686
index f14d09c4..0715271b 100644
--- a/core/linux/config.i686
+++ b/core/linux/config.i686
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.19.1-arch1 Kernel Configuration
+# Linux/x86 4.19.2-arch1 Kernel Configuration
#
#
@@ -9353,7 +9353,6 @@ CONFIG_CRYPTO_SEED=m
CONFIG_CRYPTO_SERPENT=m
CONFIG_CRYPTO_SERPENT_SSE2_586=m
CONFIG_CRYPTO_SM4=m
-# CONFIG_CRYPTO_SPECK is not set
CONFIG_CRYPTO_TEA=m
CONFIG_CRYPTO_TWOFISH=m
CONFIG_CRYPTO_TWOFISH_COMMON=m
diff --git a/core/systemd/PKGBUILD b/core/systemd/PKGBUILD
deleted file mode 100644
index be057de8..00000000
--- a/core/systemd/PKGBUILD
+++ /dev/null
@@ -1,11 +0,0 @@
-# LZ4 test fails, see upstream FS#60239
-
-source+=(lz4-test-compress-partial.patch)
-sha512sums+=('afc199c8d091c1b87fa0719b82bb29ff32595d51034127d1a8c7f83f539f52d0d8a4fa90cf22e286bf3e9104603ecfc9275c3527b9adc2d05d9bcb9234e3c208')
-
-eval "$(
- declare -f prepare | \
- sed '
- /patch.*/a patch -Np1 -i ../lz4-test-compress-partial.patch
- '
-)"
diff --git a/core/systemd/lz4-test-compress-partial.patch b/core/systemd/lz4-test-compress-partial.patch
deleted file mode 100644
index 421e186f..00000000
--- a/core/systemd/lz4-test-compress-partial.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/meson.build b/meson.build
-index 554e67e5dd..3636a0ff8c 100644
---- a/meson.build
-+++ b/meson.build
-@@ -1084,6 +1084,7 @@ conf.set10('HAVE_XZ', have)
- want_lz4 = get_option('lz4')
- if want_lz4 != 'false' and not fuzzer_build
- liblz4 = dependency('liblz4',
-+ version : '>= 1.8.3',
- required : want_lz4 == 'true')
- have = liblz4.found()
- else
-diff --git a/src/journal/test-compress.c b/src/journal/test-compress.c
-index 7addf318d6..fb0db190b2 100644
---- a/src/journal/test-compress.c
-+++ b/src/journal/test-compress.c
-@@ -227,13 +227,10 @@ static void test_lz4_decompress_partial(void) {
- assert_se(r >= 0);
- log_info("Decompressed partial %i/%i → %i", 12, HUGE_SIZE, r);
-
-- /* We expect this to fail, because that's how current lz4 works. If this
-- * call succeeds, then lz4 has been fixed, and we need to change our code.
-- */
- r = LZ4_decompress_safe_partial(buf, huge,
- compressed,
- 12, HUGE_SIZE-1);
-- assert_se(r < 0);
-+ assert_se(r >= 0);
- log_info("Decompressed partial %i/%i → %i", 12, HUGE_SIZE-1, r);
- }
- #endif