summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-07-11 05:56:08 +0000
committerAndreas Baumann <mail@andreasbaumann.cc>2018-07-11 05:56:08 +0000
commit364b65c994d05f38883547005ff8f74fdb8ef19e (patch)
treec2570d2c006a6509aedcdd34ffc884e8501963ad /core
parent9052ce7048ad4d38b6145f675bf1cdcefe83d1cb (diff)
downloadpackages-364b65c994d05f38883547005ff8f74fdb8ef19e.tar.xz
core/pinentry: added i486-specific patches
Diffstat (limited to 'core')
-rw-r--r--core/pinentry/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/core/pinentry/PKGBUILD b/core/pinentry/PKGBUILD
new file mode 100644
index 00000000..3d372f63
--- /dev/null
+++ b/core/pinentry/PKGBUILD
@@ -0,0 +1,26 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no libsecret
+ depends=(${depends[@]//libsecret/})
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-libsecret/--disable-libsecret/
+ '
+ )"
+
+ # no GUI stuff
+ makedepends=(${makedepends[@]//gtk2/})
+ makedepends=(${makedepends[@]//qt5-base/})
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-pinentry-gtk2/--disable-pinentry-gtk2/
+ s/--enable-pinentry-gnome3/--disable-pinentry-gnome3/
+ s/--enable-pinentry-qt/--disable-pinentry-qt/
+ '
+ )"
+
+ # no gcr
+ makedepends=(${makedepends[@]//gcr/})
+fi