summaryrefslogtreecommitdiff
path: root/core/pcmciautils/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2018-06-29 09:52:40 +0200
committerErich Eckner <git@eckner.net>2018-06-29 09:52:56 +0200
commit345ebe05f19d719ac4838f5c99665dcee81d7dfc (patch)
tree30049900994ef08953ad3d9c18d1fc6f601355aa /core/pcmciautils/PKGBUILD
parent66e6d1deaf8513311b0944b4589b003a55c91c85 (diff)
downloadpackages-345ebe05f19d719ac4838f5c99665dcee81d7dfc.tar.xz
core/pcmciautils reintroduced
Diffstat (limited to 'core/pcmciautils/PKGBUILD')
-rw-r--r--core/pcmciautils/PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/core/pcmciautils/PKGBUILD b/core/pcmciautils/PKGBUILD
new file mode 100644
index 00000000..d16f9a7d
--- /dev/null
+++ b/core/pcmciautils/PKGBUILD
@@ -0,0 +1,35 @@
+# $Id$
+# Maintainer: Andreas Baumann <mail@andreasbaumann.cc>
+# Contributor: Tom Gundersen <teg@jklm.no>
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+pkgname=pcmciautils
+pkgver=018
+pkgrel=8
+pkgdesc="Utilities for inserting and removing PCMCIA cards"
+arch=('i686' 'x86_64')
+url="http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmcia.html"
+license=('GPL')
+groups=('base')
+depends=('systemd')
+conflicts=('pcmcia-cs')
+source=(https://kernel.org/pub/linux/utils/kernel/pcmcia/${pkgname}-${pkgver}.tar.{xz,sign}
+ initcpio-install-pcmcia)
+options=(!makeflags)
+sha512sums=('69a01cb4d6cefc4bcb31309fafbd76f937dd0599fbd097a5f22d76d3bc4eeddfccd16bddf42d8e079b323bd8eb62f4b0b25e1da3755664bd01cb2ccbf939c7cf'
+ 'SKIP'
+ '8e486c7432264bdce6698c3831f89b1473400b99dc5aad70df70b2b01cd4219066595fe3f7bc062c56cc2487ad9d65bb6d27d843e20ebfb03e5479f69a9d5299')
+validpgpkeys=('DD46DC35691C79509D15F58CFEF39108F6FD2C20')
+
+build() {
+ cd "$pkgname-$pkgver"
+ sed -i -e 's,/lib/udev,/usr/lib/udev,g' Makefile
+ sed -i -e 's,/sbin,/usr/bin,g' Makefile
+ make
+}
+
+package() {
+ make -C "$pkgname-$pkgver" DESTDIR="$pkgdir" install
+
+ # install the mkinitpcio hook
+ install -Dm644 initcpio-install-pcmcia "$pkgdir/usr/lib/initcpio/install/pcmcia"
+}