summaryrefslogtreecommitdiff
path: root/core/m4/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2020-03-05 10:12:42 +0100
committerErich Eckner <git@eckner.net>2020-03-05 10:12:42 +0100
commit2daf5647b6961ff6281d5c89b50783e5258a6b4b (patch)
tree0ff7915683c1d5e0095605912940f94cb65c1643 /core/m4/PKGBUILD
parent3271f6ab8a92141c0e6e696b327198795f611006 (diff)
downloadpackages-2daf5647b6961ff6281d5c89b50783e5258a6b4b.tar.xz
do not overwrite prepare if it already existed
Diffstat (limited to 'core/m4/PKGBUILD')
-rw-r--r--core/m4/PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/core/m4/PKGBUILD b/core/m4/PKGBUILD
index ad7195a3..99059a2a 100644
--- a/core/m4/PKGBUILD
+++ b/core/m4/PKGBUILD
@@ -2,8 +2,14 @@
source+=('m4-1.4.18-glibc-change-work-around.patch')
md5sums+=('01968e8f3a5be62de1c849668db8042b')
-prepare() {
- cd $pkgname-$pkgver
- patch -p1 -i "$srcdir/m4-1.4.18-glibc-change-work-around.patch"
- echo "#define _IO_IN_BACKUP 0x100" >> lib/stdio-impl.h
-}
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i cd $pkgname-$pkgver \
+ patch -p1 -i "$srcdir/m4-1.4.18-glibc-change-work-around.patch" \
+ echo "#define _IO_IN_BACKUP 0x100" >> lib/stdio-impl.h
+ '
+)"