summaryrefslogtreecommitdiff
path: root/core/binutils
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-04-17 11:04:31 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-04-17 11:04:31 +0200
commit73e54b7d115ec0d4e7dc63ded9470788bd861645 (patch)
treeff7abcf0f5e60ec0a7296c4fc73eeec1d4a618b4 /core/binutils
parent3166638ea5580e1f63e17ca03c9b149859555f3d (diff)
downloadpackages-73e54b7d115ec0d4e7dc63ded9470788bd861645.tar.xz
core/binutils: fix libiberty.a on i486
Diffstat (limited to 'core/binutils')
-rw-r--r--core/binutils/PKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/core/binutils/PKGBUILD b/core/binutils/PKGBUILD
index cd9dd9a2..c275c111 100644
--- a/core/binutils/PKGBUILD
+++ b/core/binutils/PKGBUILD
@@ -59,6 +59,8 @@ fi
# i486-specific: disable PGO/LTO build, uses too much resources,
# also disabling LTO for now, also disabling the gold linker
# as it runs out of disk space (whatever that means)
+# also use the normal version of libiberty.a, there is no PIC
+# version on i486 for now
if [ "${CARCH}" = "i486" ]; then
eval "$(
declare -f build | \
@@ -67,6 +69,10 @@ if [ "${CARCH}" = "i486" ]; then
s/--enable-lto/--disable-lto/
s/--enable-gold/--disable-gold/
'
+ declare -f package | \
+ sed '
+ /pic\/libiberty.a/d
+ '
)"
fi