summaryrefslogtreecommitdiff
path: root/core/binutils/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2020-03-15 08:00:23 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2020-03-15 08:00:23 +0100
commit55f85c27b7abf93c931eb2348851fda2ce2169ba (patch)
tree84e4409478a6294a0d27a87e10ef41b96cfab8cf /core/binutils/PKGBUILD
parent207dc53d966914f673650e4363e91dd6f4ec1e5f (diff)
downloadpackages-55f85c27b7abf93c931eb2348851fda2ce2169ba.tar.xz
core/binutils:
- removed --with-debuginfod, fails with "configure: error: debuginfod is missing or unusable" - removed --enable-targets=x86_64-pep (we don't develop 64-bit EFI binaries on 32-bit) - removed --enable-64-bit-bfd for non-64-bit targets
Diffstat (limited to 'core/binutils/PKGBUILD')
-rw-r--r--core/binutils/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/core/binutils/PKGBUILD b/core/binutils/PKGBUILD
index 71467e4b..9e9b625c 100644
--- a/core/binutils/PKGBUILD
+++ b/core/binutils/PKGBUILD
@@ -26,6 +26,31 @@ eval "$(
'
)"
+# "configure: error: debuginfod is missing or unusable"
+eval "$(
+ declare -f build | \
+ sed '
+ s/--with-debuginfod//g
+ '
+)"
+
+# should be in a cross-compilation binutils for targeting EFI binaries IMHO,
+# not in the main platform binutils (see also https://bugs.archlinux.org/task/42540)
+eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-targets=x86_64-pep//g
+ '
+)"
+
+# --enable-64-bit-bfd makes sense only for 64-bit targets IMHO
+eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-64-bit-bfd//g
+ '
+)"
+
# i486-specific
if [ "${CARCH}" = "i486" ]; then
# disable CET (Control Flow instructions endbr32/enbr64)