summaryrefslogtreecommitdiff
path: root/core/binutils/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-07-21 08:58:48 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-07-21 08:58:48 +0200
commit0d9dcdd38f57cf61c8c5c282e68c7c3d7d4bfc96 (patch)
tree2736ca5d098f72204ab4661a26135410771937e7 /core/binutils/PKGBUILD
parent541f7dbe2fba4e9ad87701c1169f17525c20ae21 (diff)
downloadpackages-0d9dcdd38f57cf61c8c5c282e68c7c3d7d4bfc96.tar.xz
core/binutils: trying to enable CET properly
Diffstat (limited to 'core/binutils/PKGBUILD')
-rw-r--r--core/binutils/PKGBUILD15
1 files changed, 14 insertions, 1 deletions
diff --git a/core/binutils/PKGBUILD b/core/binutils/PKGBUILD
index 711a8ed0..71467e4b 100644
--- a/core/binutils/PKGBUILD
+++ b/core/binutils/PKGBUILD
@@ -32,7 +32,20 @@ if [ "${CARCH}" = "i486" ]; then
eval "$(
declare -f build | \
sed '
- s,configure",configure" --disable-cet,
+ s,configure",configure" --enable-cet=no,
+ '
+ )"
+else
+ # explicitely enable CET (Control Flow instructions endbr32/enbr64)
+ # avoid "corrupt GNU_PROPERTY_TYPE (5) size: 0" warnings,
+ # see:
+ # https://bbs.archlinux32.org/viewtopic.php?pid=6160#p6160
+ # https://bugs.archlinux32.org/index.php?do=details&task_id=82
+ #
+ eval "$(
+ declare -f build | \
+ sed '
+ s,configure",configure" --enable-cet=yes,
'
)"
fi