summaryrefslogtreecommitdiff
path: root/core/autoconf/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-07-06 14:16:14 +0000
committerAndreas Baumann <mail@andreasbaumann.cc>2018-07-06 14:16:14 +0000
commitcd8798e269c2bf11a8b41843185b2c4d8ca9dddd (patch)
treebf6261fb06c0b5e79afba6b5131410394dbebce4 /core/autoconf/PKGBUILD
parentdd9fa07939a7b1f6fd67def3c56358bbe4e7a493 (diff)
downloadpackages-cd8798e269c2bf11a8b41843185b2c4d8ca9dddd.tar.xz
core/autoconf: added i486 specific patches
Diffstat (limited to 'core/autoconf/PKGBUILD')
-rw-r--r--core/autoconf/PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/core/autoconf/PKGBUILD b/core/autoconf/PKGBUILD
index 1957adf9..320aba12 100644
--- a/core/autoconf/PKGBUILD
+++ b/core/autoconf/PKGBUILD
@@ -6,3 +6,21 @@ if [ "${pkgname}-${pkgver}-${pkgrel}" = autoconf-2.69-4 ]; then
'
)"
fi
+
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # testing the go macros requires a running go actually
+ checkdepends+=('gcc-go')
+
+ # autoconf: 351 Go: https://lists.gnu.org/archive/html/bug-autoconf/2013-01/msg00000.html,
+ # see FS#57870 (closed upstream)
+ source+=('autoconf-2.69-go-test-351-OpenFile.patch')
+ md5sums+=('a7e1e05d4372b2ef5fae29b59e677e7d')
+ eval "$(
+ declare -f prepare | \
+ sed '
+ /patch -p1.*libtool/ a \
+ patch -Np1 -i "${srcdir}/autoconf-2.69-go-test-351-OpenFile.patch"
+ '
+ )"
+fi