summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2018-08-16 16:43:30 +0200
committerErich Eckner <git@eckner.net>2018-08-16 16:43:30 +0200
commitf88a10a63c3de0c70c304d90cd27bc5879973fc5 (patch)
treecb5a307735f315ff266a4e3c4541987991815901 /community
parenta17be8ed8b3483cd4c7e6cf629be42fc7cca5e39 (diff)
downloadpackages-f88a10a63c3de0c70c304d90cd27bc5879973fc5.tar.xz
community/spring: make patch position-independent
Diffstat (limited to 'community')
-rw-r--r--community/spring/PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/community/spring/PKGBUILD b/community/spring/PKGBUILD
index 749aaed2..de42cd57 100644
--- a/community/spring/PKGBUILD
+++ b/community/spring/PKGBUILD
@@ -1,6 +1,11 @@
# https://springrts.com/mantis/view.php?id=5413
-sha512sums[1]='7d29099f589f4ab70262ebb307f905bdaa7e20606421ca2efaf69d391b271d3e1015f44087161106546ebe1ef197dc758c5de0120feff3f473e69ec96555d3a8'
+for ((i=0; i<${#sha512sums[@]}; i++)); do
+ if [ "${source[${i}]}" = 'gold-linker.patch' ]; then
+ break
+ fi
+done
+sha512sums[${i}]]='7d29099f589f4ab70262ebb307f905bdaa7e20606421ca2efaf69d391b271d3e1015f44087161106546ebe1ef197dc758c5de0120feff3f473e69ec96555d3a8'
eval "$(
declare -f prepare | \