summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-05-04 18:29:14 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-05-04 18:29:14 +0200
commitf500d1d8f2d67d28e905358b57ca49b14fc09741 (patch)
tree10b9a43a6e3223c48999eb7a1164438cf08e68ac /community
parent6efbe1b6a0ae582e37a8ba856d07d5b51481d81b (diff)
downloadpackages-f500d1d8f2d67d28e905358b57ca49b14fc09741.tar.xz
community/libmanette: build fixes for i486 (no vala, gtkdoc) and hotfix for FS#70706
Diffstat (limited to 'community')
-rw-r--r--community/libmanette/PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/community/libmanette/PKGBUILD b/community/libmanette/PKGBUILD
new file mode 100644
index 00000000..f47f847e
--- /dev/null
+++ b/community/libmanette/PKGBUILD
@@ -0,0 +1,18 @@
+# no Vala and broken gtkdoc on i486
+makedepends=(${makedepends[@]//vala/})
+makedepends_i686+=(vala)
+makedepends_pentium4=("${makedepends_i686[@]}")
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/arch-meson/arch-meson -D vapi=false/
+ '
+ )"
+fi
+
+# libudev.pc is in systemd (FS#70706)
+makedepends+=(systemd)
+
+# missing gtk-doc
+makedepends+=(gtk-doc)