summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-08-31 14:10:35 +0000
committerAndreas Baumann <mail@andreasbaumann.cc>2018-08-31 14:10:35 +0000
commit9184124a1226c075e9332bc1b6c9eac255e72f13 (patch)
tree5bbadf336f0357cbdd2664d67db772339b345df4 /community
parenta1f423a90571754237a99f0a7f799939cb3b1aef (diff)
downloadpackages-9184124a1226c075e9332bc1b6c9eac255e72f13.tar.xz
rebuilt all python 3.7.0 with boostrapped pip/wheel/setuptools on i486
Diffstat (limited to 'community')
-rw-r--r--community/docutils/PKGBUILD5
-rw-r--r--community/python-apipkg/PKGBUILD1
-rw-r--r--community/python-atomicwrites/PKGBUILD1
-rw-r--r--community/python-babel/PKGBUILD1
-rw-r--r--community/python-cachecontrol/PKGBUILD1
-rw-r--r--community/python-colorama/PKGBUILD5
-rw-r--r--community/python-distlib/PKGBUILD1
-rw-r--r--community/python-distro/PKGBUILD3
-rw-r--r--community/python-html5lib/PKGBUILD1
-rw-r--r--community/python-imagesize/PKGBUILD5
-rw-r--r--community/python-iniconfig/PKGBUILD1
-rw-r--r--community/python-jinja/PKGBUILD5
-rw-r--r--community/python-lockfile/PKGBUILD1
-rw-r--r--community/python-mock/PKGBUILD2
-rw-r--r--community/python-more-itertools/PKGBUILD4
-rw-r--r--community/python-msgpack/PKGBUILD1
-rw-r--r--community/python-ndg-httpsclient/PKGBUILD5
-rw-r--r--community/python-pbr/PKGBUILD1
-rw-r--r--community/python-pluggy/PKGBUILD1
-rw-r--r--community/python-progress/PKGBUILD5
-rw-r--r--community/python-py/PKGBUILD1
-rw-r--r--community/python-pygments/PKGBUILD5
-rw-r--r--community/python-pysocks/PKGBUILD6
-rw-r--r--community/python-pytest/PKGBUILD2
-rw-r--r--community/python-pytoml/PKGBUILD5
-rw-r--r--community/python-pytz/PKGBUILD5
-rw-r--r--community/python-snowballstemmer/PKGBUILD5
-rw-r--r--community/python-sphinx-alabaster-theme/PKGBUILD5
-rw-r--r--community/python-sphinx/PKGBUILD5
-rw-r--r--community/python-sphinx_rtd_theme/PKGBUILD5
-rw-r--r--community/python-sphinxcontrib-websupport/PKGBUILD5
-rw-r--r--community/python-sqlalchemy/PKGBUILD1
-rw-r--r--community/python-webencodings/PKGBUILD1
-rw-r--r--community/python-whoosh/PKGBUILD1
-rw-r--r--community/python2-enum34/PKGBUILD5
-rw-r--r--community/python2-funcsigs/PKGBUILD1
-rw-r--r--community/python2-pathlib2/PKGBUILD5
-rw-r--r--community/python2-scandir/PKGBUILD5
-rw-r--r--community/python2-typing/PKGBUILD5
39 files changed, 121 insertions, 2 deletions
diff --git a/community/docutils/PKGBUILD b/community/docutils/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/docutils/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-apipkg/PKGBUILD b/community/python-apipkg/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-apipkg/PKGBUILD
+++ b/community/python-apipkg/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-atomicwrites/PKGBUILD b/community/python-atomicwrites/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-atomicwrites/PKGBUILD
+++ b/community/python-atomicwrites/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-babel/PKGBUILD b/community/python-babel/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-babel/PKGBUILD
+++ b/community/python-babel/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-cachecontrol/PKGBUILD b/community/python-cachecontrol/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-cachecontrol/PKGBUILD
+++ b/community/python-cachecontrol/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-colorama/PKGBUILD b/community/python-colorama/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-colorama/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-distlib/PKGBUILD b/community/python-distlib/PKGBUILD
index 870e034f..bd57ba9d 100644
--- a/community/python-distlib/PKGBUILD
+++ b/community/python-distlib/PKGBUILD
@@ -1,5 +1,6 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
# currently tests are failing, they are disabled not due to dependencies
unset check
fi
diff --git a/community/python-distro/PKGBUILD b/community/python-distro/PKGBUILD
index 32d99307..416ab6ac 100644
--- a/community/python-distro/PKGBUILD
+++ b/community/python-distro/PKGBUILD
@@ -1,5 +1,8 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+
# disable sphinx for now, needs too many packages
makedepends=(${makedepends[@]//python-sphinx/})
makedepends=(${makedepends[@]//python2-sphinx/})
diff --git a/community/python-html5lib/PKGBUILD b/community/python-html5lib/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-html5lib/PKGBUILD
+++ b/community/python-html5lib/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-imagesize/PKGBUILD b/community/python-imagesize/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-imagesize/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-iniconfig/PKGBUILD b/community/python-iniconfig/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-iniconfig/PKGBUILD
+++ b/community/python-iniconfig/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-jinja/PKGBUILD b/community/python-jinja/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-jinja/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-lockfile/PKGBUILD b/community/python-lockfile/PKGBUILD
index e50d2ff2..1c6c782d 100644
--- a/community/python-lockfile/PKGBUILD
+++ b/community/python-lockfile/PKGBUILD
@@ -1,5 +1,6 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
makedepends+=('python-pbr' 'python2-pbr')
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-mock/PKGBUILD b/community/python-mock/PKGBUILD
index e50d2ff2..22a68305 100644
--- a/community/python-mock/PKGBUILD
+++ b/community/python-mock/PKGBUILD
@@ -1,5 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
- makedepends+=('python-pbr' 'python2-pbr')
+ makedepends+=('python-pbr' 'python2-pbr' 'python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-more-itertools/PKGBUILD b/community/python-more-itertools/PKGBUILD
new file mode 100644
index 00000000..3b5f7de0
--- /dev/null
+++ b/community/python-more-itertools/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+fi
diff --git a/community/python-msgpack/PKGBUILD b/community/python-msgpack/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-msgpack/PKGBUILD
+++ b/community/python-msgpack/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-ndg-httpsclient/PKGBUILD b/community/python-ndg-httpsclient/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-ndg-httpsclient/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-pbr/PKGBUILD b/community/python-pbr/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-pbr/PKGBUILD
+++ b/community/python-pbr/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-pluggy/PKGBUILD b/community/python-pluggy/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-pluggy/PKGBUILD
+++ b/community/python-pluggy/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-progress/PKGBUILD b/community/python-progress/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-progress/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-py/PKGBUILD b/community/python-py/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-py/PKGBUILD
+++ b/community/python-py/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-pygments/PKGBUILD b/community/python-pygments/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-pygments/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-pysocks/PKGBUILD b/community/python-pysocks/PKGBUILD
index 20354d08..e05c2c4b 100644
--- a/community/python-pysocks/PKGBUILD
+++ b/community/python-pysocks/PKGBUILD
@@ -1,3 +1,9 @@
# check() is disabled
unset checkdepends
+unset check
+
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+fi
diff --git a/community/python-pytest/PKGBUILD b/community/python-pytest/PKGBUILD
index 6c63d86f..f06df55f 100644
--- a/community/python-pytest/PKGBUILD
+++ b/community/python-pytest/PKGBUILD
@@ -1,5 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
- makedepends+=('python-setuptools-scm' 'python2-setuptools-scm')
+ makedepends+=('python-setuptools-scm' 'python2-setuptools-scm' 'python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-pytoml/PKGBUILD b/community/python-pytoml/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-pytoml/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-pytz/PKGBUILD b/community/python-pytz/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-pytz/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-snowballstemmer/PKGBUILD b/community/python-snowballstemmer/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-snowballstemmer/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-sphinx-alabaster-theme/PKGBUILD b/community/python-sphinx-alabaster-theme/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-sphinx-alabaster-theme/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-sphinx/PKGBUILD b/community/python-sphinx/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-sphinx/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-sphinx_rtd_theme/PKGBUILD b/community/python-sphinx_rtd_theme/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-sphinx_rtd_theme/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-sphinxcontrib-websupport/PKGBUILD b/community/python-sphinxcontrib-websupport/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python-sphinxcontrib-websupport/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python-sqlalchemy/PKGBUILD b/community/python-sqlalchemy/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-sqlalchemy/PKGBUILD
+++ b/community/python-sqlalchemy/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-webencodings/PKGBUILD b/community/python-webencodings/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-webencodings/PKGBUILD
+++ b/community/python-webencodings/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python-whoosh/PKGBUILD b/community/python-whoosh/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python-whoosh/PKGBUILD
+++ b/community/python-whoosh/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python2-enum34/PKGBUILD b/community/python2-enum34/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python2-enum34/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/community/python2-funcsigs/PKGBUILD b/community/python2-funcsigs/PKGBUILD
index ed73f8de..31dffbd8 100644
--- a/community/python2-funcsigs/PKGBUILD
+++ b/community/python2-funcsigs/PKGBUILD
@@ -1,4 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
unset check
fi
diff --git a/community/python2-pathlib2/PKGBUILD b/community/python2-pathlib2/PKGBUILD
new file mode 100644
index 00000000..6c63d86f
--- /dev/null
+++ b/community/python2-pathlib2/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-setuptools-scm' 'python2-setuptools-scm')
+ unset check
+fi
diff --git a/community/python2-scandir/PKGBUILD b/community/python2-scandir/PKGBUILD
new file mode 100644
index 00000000..6c63d86f
--- /dev/null
+++ b/community/python2-scandir/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-setuptools-scm' 'python2-setuptools-scm')
+ unset check
+fi
diff --git a/community/python2-typing/PKGBUILD b/community/python2-typing/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/community/python2-typing/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi