summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2017-09-29 06:54:51 +0200
committerErich Eckner <git@eckner.net>2017-09-29 06:54:51 +0200
commit755b34b2cd795c06a90b35c2077b9c427d4ddf54 (patch)
tree50797b5dcb26a80d6603281bd043bf38688dd08b /community
parentc41200de96f2700ccce85f341b6b31962e820c5b (diff)
downloadpackages-755b34b2cd795c06a90b35c2077b9c427d4ddf54.tar.xz
community/ponyc: patch for openssl-1.0
Diffstat (limited to 'community')
-rw-r--r--community/ponyc/PKGBUILD14
-rw-r--r--community/ponyc/pony-ssl-1.0-compat.patch35
2 files changed, 48 insertions, 1 deletions
diff --git a/community/ponyc/PKGBUILD b/community/ponyc/PKGBUILD
index a0560166..d91fd71f 100644
--- a/community/ponyc/PKGBUILD
+++ b/community/ponyc/PKGBUILD
@@ -1,6 +1,18 @@
# It seems, compiling for i686 is as simple as specifying you want i686.
+depends+=('openssl-1.0')
+source+=('pony-ssl-1.0-compat.patch')
+sha512sums+=('3256eba9398cc0f0a933d7e54321476d2847a95ca627571cc0911e758d3b29cf4c91d6dbe2a7c1905a8d8c0b1cb7472c5139c7df2bb6e0530c9c15d49f06ade4')
+
eval "$(
declare -f build check | \
- sed 's|x86-64|i686|'
+ sed '
+ s|x86-64|i686|
+ s|make |make default_pic=true|
+ '
+ declare -f prepare | \
+ sed '
+ /}/ i
+ patch -Np1 -i "$srcdir/pony-ssl-1.0-compat.patch"
+ '
)"
diff --git a/community/ponyc/pony-ssl-1.0-compat.patch b/community/ponyc/pony-ssl-1.0-compat.patch
new file mode 100644
index 00000000..93fdf973
--- /dev/null
+++ b/community/ponyc/pony-ssl-1.0-compat.patch
@@ -0,0 +1,35 @@
+diff --git a/packages/crypto/digest.pony b/packages/crypto/digest.pony
+index 9b88fb45..7afeb847 100644
+--- a/packages/crypto/digest.pony
++++ b/packages/crypto/digest.pony
+@@ -1,5 +1,5 @@
+ use "path:/usr/local/opt/libressl/lib" if osx
+-use "lib:crypto"
++use "lib:/usr/lib/libcrypto.so.1.0.0"
+
+ primitive _EVPMD
+ primitive _EVPCTX
+diff --git a/packages/crypto/hash_fn.pony b/packages/crypto/hash_fn.pony
+index b3edc5cf..2d48f99c 100644
+--- a/packages/crypto/hash_fn.pony
++++ b/packages/crypto/hash_fn.pony
+@@ -1,5 +1,5 @@
+ use "path:/usr/local/opt/libressl/lib" if osx
+-use "lib:crypto"
++use "lib:/usr/lib/libcrypto.so.1.0.0"
+
+ use "format"
+
+diff --git a/packages/net/ssl/_ssl_init.pony b/packages/net/ssl/_ssl_init.pony
+index 26a48d26..e861a086 100644
+--- a/packages/net/ssl/_ssl_init.pony
++++ b/packages/net/ssl/_ssl_init.pony
+@@ -1,6 +1,6 @@
+ use "path:/usr/local/opt/libressl/lib" if osx
+-use "lib:ssl"
+-use "lib:crypto"
++use "lib:/usr/lib/libssl.so.1.0.0"
++use "lib:/usr/lib/libcrypto.so.1.0.0"
+
+ primitive _SSLInit
+ """