summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-21 10:09:43 +0100
committerErich Eckner <git@eckner.net>2019-01-21 10:09:43 +0100
commit70a7c30b8196a4398cf755b93507516d0f83be56 (patch)
tree209c100961292220e8af6a75f6eccf2cf9a0e440 /community
parent22d62828d91c69d6ec0db0ab42be321a0370f561 (diff)
parentbdaf29915201bec1e7ebffb37bf9f96a7dd529e8 (diff)
downloadpackages-70a7c30b8196a4398cf755b93507516d0f83be56.tar.xz
Merge branch 'master' into i486
Diffstat (limited to 'community')
-rw-r--r--community/eclipse/PKGBUILD9
-rw-r--r--community/grim/PKGBUILD7
-rw-r--r--community/grim/bced8c88165bd15cf97d3b55a9241b0a6ee1fe3c.patch80
-rw-r--r--community/nvidia-cg-toolkit/PKGBUILD13
-rw-r--r--community/pypy3/PKGBUILD5
5 files changed, 114 insertions, 0 deletions
diff --git a/community/eclipse/PKGBUILD b/community/eclipse/PKGBUILD
new file mode 100644
index 00000000..c1a4a6db
--- /dev/null
+++ b/community/eclipse/PKGBUILD
@@ -0,0 +1,9 @@
+# we want the i686 binaries!
+source=("${source[@]/-x86_64/}")
+sha256sums=('70ae1934385b0b7c25e5a76bfcd6d092bfd8d19ce451c3d909afa3cf2448452e'
+ 'c33337a1740a84aabec3bd256f4256c8693ab0d1f755c120614bd28ae354f326'
+ '6e7b70d73cfe8e7f565465149ddb7d1b4854cba9f3281d370e54c12b1449272d'
+ '87ebe3451291a3152eb21bd588ae1ebb06538b62b5f3c5fabec2600accb8adea'
+ '59eb59fd362e4daa0b17bb87a2fbb1019dfb86be1546f398055f491c6303476b'
+ '09db32c2d958e357b3a959a6860240f3e1eb40f7ffa1815f31661f7f117dd980'
+ 'c7c40966c6cecb719f43487476a52e84f86f680fc34d3be7ae535e03be212b4f')
diff --git a/community/grim/PKGBUILD b/community/grim/PKGBUILD
new file mode 100644
index 00000000..4c7f6cf1
--- /dev/null
+++ b/community/grim/PKGBUILD
@@ -0,0 +1,7 @@
+# temporary fix for type mismatch
+source+=('bced8c88165bd15cf97d3b55a9241b0a6ee1fe3c.patch')
+sha256sums+=('9614a426ac697cacbb7e08f6d5a12466071052d7ae14ef31a05e51d50f510de1')
+prepare() {
+ cd "$pkgname"
+ patch -p1 -i '../bced8c88165bd15cf97d3b55a9241b0a6ee1fe3c.patch'
+}
diff --git a/community/grim/bced8c88165bd15cf97d3b55a9241b0a6ee1fe3c.patch b/community/grim/bced8c88165bd15cf97d3b55a9241b0a6ee1fe3c.patch
new file mode 100644
index 00000000..48afa84f
--- /dev/null
+++ b/community/grim/bced8c88165bd15cf97d3b55a9241b0a6ee1fe3c.patch
@@ -0,0 +1,80 @@
+From aa679f0501a30fb5a452d35f7ef9d7ed2c3fa2f9 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jan=20Pokorn=C3=BD?= <jpokorny@fedoraproject.org>
+Date: Sat, 3 Nov 2018 15:16:08 +0100
+Subject: [PATCH] Fix i686 build -Werror=incompatible-pointer-types complaint
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This was caused with jpeg_mem_dest expecting pointer to unsigned long
+and being fed with pointer to size_t, which may amount to different
+data-width types. There's also a simple overflow check for such
+cases now.
+
+Signed-off-by: Jan Pokorný <jpokorny@fedoraproject.org>
+---
+ cairo_jpg.c | 17 +++++++++--------
+ include/cairo_jpg.h | 2 +-
+ 2 files changed, 10 insertions(+), 9 deletions(-)
+
+diff --git a/cairo_jpg.c b/cairo_jpg.c
+index e905e4e..3a37a37 100644
+--- a/cairo_jpg.c
++++ b/cairo_jpg.c
+@@ -7,7 +7,9 @@
+ #include <stdlib.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#include <assert.h>
+ #include <fcntl.h>
++#include <limits.h>
+ #include <unistd.h>
+ #include <cairo.h>
+ #include <jpeglib.h>
+@@ -15,7 +17,7 @@
+ #include "cairo_jpg.h"
+
+ cairo_status_t cairo_surface_write_to_jpeg_mem(cairo_surface_t *sfc,
+- unsigned char **data, size_t *len, int quality) {
++ unsigned char **data, unsigned long *len, int quality) {
+ struct jpeg_compress_struct cinfo;
+ struct jpeg_error_mgr jerr;
+ JSAMPROW row_pointer[1];
+@@ -91,18 +93,17 @@ cairo_status_t cairo_surface_write_to_jpeg_stream(cairo_surface_t *sfc,
+ cairo_write_func_t write_func, void *closure, int quality) {
+ cairo_status_t e;
+ unsigned char *data = NULL;
+- size_t len = 0;
++ unsigned long len = 0;
+
+ e = cairo_surface_write_to_jpeg_mem(sfc, &data, &len, quality);
+- if (e != CAIRO_STATUS_SUCCESS) {
+- return e;
++ if (e == CAIRO_STATUS_SUCCESS) {
++ assert(sizeof(unsigned long) <= sizeof(size_t)
++ || !(len >> (sizeof(size_t) * CHAR_BIT)));
++ e = write_func(closure, data, len);
++ free(data);
+ }
+
+- e = write_func(closure, data, len);
+-
+- free(data);
+ return e;
+-
+ }
+
+ cairo_status_t cairo_surface_write_to_jpeg(cairo_surface_t *sfc,
+diff --git a/include/cairo_jpg.h b/include/cairo_jpg.h
+index a2d0328..7e09e55 100644
+--- a/include/cairo_jpg.h
++++ b/include/cairo_jpg.h
+@@ -3,7 +3,7 @@
+
+ #include <cairo.h>
+
+-cairo_status_t cairo_surface_write_to_jpeg_mem(cairo_surface_t *sfc, unsigned char **data, size_t *len, int quality);
++cairo_status_t cairo_surface_write_to_jpeg_mem(cairo_surface_t *sfc, unsigned char **data, unsigned long *len, int quality);
+ cairo_status_t cairo_surface_write_to_jpeg_stream(cairo_surface_t *sfc, cairo_write_func_t write_func, void *closure, int quality);
+ cairo_status_t cairo_surface_write_to_jpeg(cairo_surface_t *sfc, const char *filename, int quality);
+
diff --git a/community/nvidia-cg-toolkit/PKGBUILD b/community/nvidia-cg-toolkit/PKGBUILD
new file mode 100644
index 00000000..b88fdd78
--- /dev/null
+++ b/community/nvidia-cg-toolkit/PKGBUILD
@@ -0,0 +1,13 @@
+source_i686=(
+ $(
+ printf '%s\n' "${source_x86_64[@]}" | \
+ sed '
+ s/_x86_64\.tgz$/_x86.tgz/
+ t
+ d
+ '
+ )
+)
+md5sums_i686=(
+ '9a9fc5108154808f3b10eafa54df1c74'
+)
diff --git a/community/pypy3/PKGBUILD b/community/pypy3/PKGBUILD
new file mode 100644
index 00000000..e7388a20
--- /dev/null
+++ b/community/pypy3/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # testing deterministically kills build slaves..
+ unset check
+fi