summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-02-12 11:24:55 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2021-02-12 11:24:55 +0100
commit6e4644aea1912fe65f0647b83598c56e0ed19cf3 (patch)
tree882cad0a378f19514d16556b7907beb01930c48a /community
parent3f4b0aba086e4c750d0af8be6a0e7335e4ff81a0 (diff)
downloadpackages-6e4644aea1912fe65f0647b83598c56e0ed19cf3.tar.xz
community/trojita: all patched upstream now, removed local patching
Diffstat (limited to 'community')
-rw-r--r--community/trojita/PKGBUILD14
-rw-r--r--community/trojita/trojita-0.7-QPainterPath.patch11
-rw-r--r--community/trojita/trojita-fix-crash.patch30
3 files changed, 0 insertions, 55 deletions
diff --git a/community/trojita/PKGBUILD b/community/trojita/PKGBUILD
deleted file mode 100644
index 4cf46311..00000000
--- a/community/trojita/PKGBUILD
+++ /dev/null
@@ -1,14 +0,0 @@
-# https://bugs.archlinux32.org/index.php?do=details&task_id=146
-# https://bugs.kde.org/show_bug.cgi?id=432827
-source+=('trojita-0.7-QPainterPath.patch')
-sha256sums+=('d8595d5970d11d9146d24332d2292f811fe4f2854574c996b97efdcdc8eedfb4')
-eval "$(
- declare -f prepare | \
- sed '
- /patch.*trojita-fix-crash/ a patch -p1 -i ../trojita-0.7-QPainterPath.patch
- '
-)"
-
-# https://bugs.archlinux32.org/index.php?do=details&task_id=146
-# patch URL run away, fetched cf2364b80fa8ae844df8350cd5833d47cce235f2 from git
-sha256sums[3]="96d5400ede5b015532d2c11b192c40f583c3b534d6d2df011d0600307e2915ea"
diff --git a/community/trojita/trojita-0.7-QPainterPath.patch b/community/trojita/trojita-0.7-QPainterPath.patch
deleted file mode 100644
index f588c2f2..00000000
--- a/community/trojita/trojita-0.7-QPainterPath.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -rauN trojita-0.7/src/Gui/Window.cpp trojita-0.7-QPainterPath-patch/src/Gui/Window.cpp
---- trojita-0.7/src/Gui/Window.cpp 2016-06-15 09:17:23.000000000 +0200
-+++ trojita-0.7-QPainterPath-patch/src/Gui/Window.cpp 2021-02-12 07:56:19.202926373 +0100
-@@ -45,6 +45,7 @@
- #include <QToolTip>
- #include <QUrl>
- #include <QWheelEvent>
-+#include <QPainterPath>
-
- #include "configure.cmake.h"
- #include "Common/Application.h"
diff --git a/community/trojita/trojita-fix-crash.patch b/community/trojita/trojita-fix-crash.patch
deleted file mode 100644
index 9a302728..00000000
--- a/community/trojita/trojita-fix-crash.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff --git a/src/Imap/Network/FileDownloadManager.cpp b/src/Imap/Network/FileDownloadManager.cpp
-index 16b6c8dfc93727bd1696abaab8336b06794b3a02..c3f72176abdfd0981a5ac37ec69060fb3c7aa797 100644
---- a/src/Imap/Network/FileDownloadManager.cpp
-+++ b/src/Imap/Network/FileDownloadManager.cpp
-@@ -139,7 +139,9 @@ void FileDownloadManager::downloadMessage()
-
- void FileDownloadManager::onPartDataTransfered()
- {
-- Q_ASSERT(reply);
-+ if (!reply) {
-+ return;
-+ }
- if (reply->error() == QNetworkReply::NoError) {
- if (!saving.open(QIODevice::WriteOnly)) {
- emit transferError(saving.errorString());
-@@ -192,11 +194,11 @@ void FileDownloadManager::onCombinerTransferError(const QString &message)
-
- void FileDownloadManager::deleteReply(QNetworkReply *reply)
- {
-- if (reply == this->reply) {
-+ if (reply && reply == this->reply) {
- if (!saved)
- onPartDataTransfered();
-- delete reply;
-- this->reply = 0;
-+ reply->deleteLater();
-+ this->reply = nullptr;
- }
- }
-