summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-21 10:03:01 +0100
committerErich Eckner <git@eckner.net>2019-01-21 10:03:01 +0100
commit6b98f5a19f2f93f145e1e5b5d1e79d6ff29620fe (patch)
tree345d5a7c3e110ecec0eeea15cbf5cb4d9fe310ff /community
parent43a901ea68bafb0dfe1818553ad131e3e36de1c4 (diff)
parent05268da81d030e81cf1bdc9293e2c218d525135f (diff)
downloadpackages-6b98f5a19f2f93f145e1e5b5d1e79d6ff29620fe.tar.xz
Merge branch 'master' into i486
Diffstat (limited to 'community')
-rw-r--r--community/firefox-developer-edition/PKGBUILD67
-rw-r--r--community/ponyc/PKGBUILD5
2 files changed, 5 insertions, 67 deletions
diff --git a/community/firefox-developer-edition/PKGBUILD b/community/firefox-developer-edition/PKGBUILD
deleted file mode 100644
index 5087c006..00000000
--- a/community/firefox-developer-edition/PKGBUILD
+++ /dev/null
@@ -1,67 +0,0 @@
-eval "$(
- declare -f build | \
- sed '
- /cd mozilla-unified/a sed -i "s/\\(cargo_rustc_flags += -C lto\\)/#\\1/" config/rules.mk
- '
- declare -f prepare | \
- sed '
- $ i export MOZ_SOURCE_CHANGESET="DEVEDITION_${pkgver//./_}_RELEASE"
- '
-)"
-for ((i=0; i<${#source[@]}; i++)); do
- infos=$(
- printf '%s\n' "${source[${i}]}" | \
- sed -n '
- s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^?#]\+\)\(?signed\)\?#\(\(tag\|commit\)=\S\+\)$@\3 \2 \4 \5 \6@
- T
- p
- '
- )
- if [ -n "${infos}" ]; then
- source[${i}]=$(
- type="${infos%% *}"
- infos="${infos#* }"
- if [ -n "${infos%% *}" ]; then
- prefix="${infos%% *}"
- else
- prefix=''
- fi
- infos="${infos#* }"
- repo="${infos%% *}"
- repo64=$(
- printf '%s' "${repo}" | \
- base64 -w0 | \
- sed 's/=/%3D/g'
- )
- infos="${infos#* }"
- if [ "${infos%% *}" = '?signed' ]; then
- key_check=$(
- printf '&valid_keys='
- printf '%s,' "${validpgpkeys[@]}" | \
- sed 's/,$//'
- )
- else
- key_check=''
- fi
- infos="${infos#* }"
- if [ -z "${prefix}" ]; then
- prefix="${repo%.git}"
- prefix="${prefix##*/}"
- fi
- prefix_64=$(
- printf '%s/' "${prefix}" | \
- base64 -w0 | \
- sed 's/=/%3D/g'
- )
-
- printf '%s-%s.tar.gz::https://archive-server.archlinux32.org/?t=%s&p=%s&r=%s%s&%s\n' \
- "${prefix}" \
- "${pkgver}" \
- "${type}" \
- "${prefix_64}" \
- "${repo64}" \
- "${key_check}" \
- "${infos}"
- )
- fi
-done
diff --git a/community/ponyc/PKGBUILD b/community/ponyc/PKGBUILD
index ded62ee4..036ee228 100644
--- a/community/ponyc/PKGBUILD
+++ b/community/ponyc/PKGBUILD
@@ -7,3 +7,8 @@ eval "$(
s|make |make default_pic=true|
'
)"
+
+# the compiler seems fine, but the test frameworks seems to break with
+# newer LLVM, for now, ignoring the tests:
+# https://github.com/ponylang/ponyc/issues/2875
+unset check